Gnome2-Vte v0.11 Perl 5 v5.29.9 OpenBSD.amd64-openbsd-thread-multi

Status
Unknown
From
Alceu Rodrigues de Freitas Junior
Dist
Gnome2-Vte v0.11
Platform
Perl 5 v5.29.9 OpenBSD.amd64-openbsd-thread-multi
Date
2019-04-12T07:52:42
ID
f3df9b7e-5cf7-11e9-9f97-b8f28032a6a0
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Brian Manning,

This is a computer-generated report for Gnome2-Vte-0.11
on perl 5.29.9, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  However, attempting to
test your distribution gave an inconclusive result.

This could be because your distribution had an error during the make/build
stage, did not define tests, tests could not be found, because your tests were
interrupted before they finished, or because the results of the tests could not
be parsed.  You may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin/perl5.29.9 Makefile.PL':

Can't locate Glib.pm in @INC (you may need to install the Glib module) (@INC contains: /tmp/CPAN-Reporter-lib-iwg3 /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/site_perl/5.29.9/OpenBSD.amd64-openbsd-thread-multi /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/site_perl/5.29.9 /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/5.29.9/OpenBSD.amd64-openbsd-thread-multi /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/5.29.9 .) at (eval 14) line 1.
BEGIN failed--compilation aborted at (eval 14) line 1.

Checking if your kit is complete...
Looks good
MakeMaker FATAL: prerequisites not found.
    Glib not installed
    Gtk2 not installed

Please install these modules first and rerun 'perl Makefile.PL'.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have   
    ------------------- ---- -------
    ExtUtils::MakeMaker 0    7.35_10


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    DBD_MYSQL_TESTDB = test
    DBD_MYSQL_TESTHOST = localhost
    DBD_MYSQL_TESTPASSWORD = 
    DBD_MYSQL_TESTPORT = 3306
    DBD_MYSQL_TESTUSER = vegeta
    EXTENDED_TESTING = 1
    PATH = /home/vegeta/perl5/perlbrew/bin:/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin:/home/vegeta/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/X11R6/bin:/usr/local/bin:/usr/local/sbin
    PERL = /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin/perl5.29.9
    PERL5LIB = 
    PERL5OPT = -I/tmp/CPAN-Reporter-lib-iwg3 -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 79683
    PERL5_CPAN_IS_EXECUTING = /mnt/cpan_build_dir/vegeta/Gnome2-Vte-0.11-0/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 79683
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 24067,79683
    PERLBREW_HOME = /home/vegeta/.perlbrew
    PERLBREW_MANPATH = /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/man
    PERLBREW_PATH = /home/vegeta/perl5/perlbrew/bin:/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin
    PERLBREW_PERL = perl-5.29.9
    PERLBREW_ROOT = /home/vegeta/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.86
    PERLBREW_VERSION = 0.86
    PERL_AUTOINSTALL = --defaultdeps
    PERL_CR_SMOKER_CURRENT = Gnome2-Vte-0.11
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/local/bin/bash
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin/perl5.29.9
    $UID/$EUID = 1002 / 1002
    $GID = 1002 1002 1001
    $EGID = 1002 1002 1001

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.26    
    CPAN::Meta          2.150010
    Cwd                 3.77    
    ExtUtils::CBuilder  0.280231
    ExtUtils::Command   7.35_10 
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.35_10 
    ExtUtils::Manifest  1.72    
    ExtUtils::ParseXS   3.35    
    File::Spec          3.77    
    JSON                4.02    
    JSON::PP            4.02    
    Module::Build       0.42_28 
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.43_01 
    Test::More          1.302162
    YAML                1.27    
    YAML::Syck          n/a     
    version             0.9924  


--

Summary of my perl5 (revision 5 version 29 subversion 9) configuration:
   
  Platform:
    osname=openbsd
    osvers=6.4
    archname=OpenBSD.amd64-openbsd-thread-multi
    uname='openbsd cpan-smoker-openbsd 6.4 generic.mp#364 amd64 '
    config_args='-de -Dprefix=/home/vegeta/perl5/perlbrew/perls/perl-5.29.9 -Dman1dir=none -Dman3dir=none -Dusemultiplicity -Duse64bitall -Dusethreads -Duse64bitint -Dusedevel -Aeval:scriptdir=/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=define
    usemultiplicity=define
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='cc'
    ccflags ='-pthread -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_FORTIFY_SOURCE=2'
    optimize='-O2'
    cppflags='-pthread -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='4.2.1 Compatible OpenBSD Clang 6.0.0 (tags/RELEASE_600/final)'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags ='-pthread -Wl,-E  -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lpthread -lm -lutil -lc
    perllibs=-lpthread -lm -lutil -lc
    libc=/usr/lib/libc.so.92.5
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags=' '
    cccdlflags='-DPIC -fPIC '
    lddlflags='-shared -fPIC  -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    MULTIPLICITY
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_IMPLICIT_CONTEXT
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    PERL_USE_DEVEL
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_ITHREADS
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
    USE_REENTRANT_API
    USE_THREAD_SAFE_LOCALE
  Locally applied patches:
    Devel::PatchPerl 1.52
  Built under openbsd
  Compiled at Mar 23 2019 11:53:14
  %ENV:
    PERL="/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin/perl5.29.9"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="79683"
    PERL5_CPAN_IS_EXECUTING="/mnt/cpan_build_dir/vegeta/Gnome2-Vte-0.11-0/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="79683"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="24067,79683"
    PERLBREW_HOME="/home/vegeta/.perlbrew"
    PERLBREW_MANPATH="/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/man"
    PERLBREW_PATH="/home/vegeta/perl5/perlbrew/bin:/home/vegeta/perl5/perlbrew/perls/perl-5.29.9/bin"
    PERLBREW_PERL="perl-5.29.9"
    PERLBREW_ROOT="/home/vegeta/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.86"
    PERLBREW_VERSION="0.86"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_CR_SMOKER_CURRENT="Gnome2-Vte-0.11"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/site_perl/5.29.9/OpenBSD.amd64-openbsd-thread-multi
    /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/site_perl/5.29.9
    /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/5.29.9/OpenBSD.amd64-openbsd-thread-multi
    /home/vegeta/perl5/perlbrew/perls/perl-5.29.9/lib/5.29.9
    .