rdapper v0.3 Perl 5 v5.8.9 i386-freebsd-thread-multi

Status
Pass
From
Chris Williams (BINGOS)
Dist
rdapper v0.3
Platform
Perl 5 v5.8.9 i386-freebsd-thread-multi
Date
2019-01-17T22:26:00
ID
de19aa0c-1aa6-11e9-86e3-404589cf513b
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear GBROWN,

This is a computer-generated error report created automatically by
CPANPLUS, version 0.9176. Testers personal comments may appear
at the end of this report.


Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

TEST RESULTS:

Below is the error stack from stage 'make test':

No tests defined for rdapper extension.


PREREQUISITES:

Here is a list of prerequisites you specified and versions we
managed to load:

	  Module Name                        Have     Want
	  ExtUtils::MakeMaker                7.34        0
	  Getopt::Long                       2.37        0
	  JSON                               4.00        0
	  List::MoreUtils                   0.428        0
	  Net::ASN                           1.07        0
	  Net::DNS::Domain                   1698        0
	  Net::IP                            1.26        0
	  Net::RDAP                          0.13        0
	  Pod::Usage                         1.35        0
	  Term::ANSIColor                    1.12        0
	  Text::Wrap                     2006.1117        0
	  URI                                1.76        0

Perl module toolchain versions installed:
	Module Name                        Have
	CPANPLUS                         0.9176
	CPANPLUS::Dist::Build              0.90
	Cwd                                3.75
	ExtUtils::CBuilder             0.280230
	ExtUtils::Command                  7.34
	ExtUtils::Install                  2.14
	ExtUtils::MakeMaker                7.34
	ExtUtils::Manifest                 1.71
	ExtUtils::ParseXS                  3.35
	File::Spec                         3.75
	Module::Build                    0.4224
	Pod::Parser                        1.35
	Pod::Simple                        3.35
	Test2                          1.302156
	Test::Harness                      3.42
	Test::More                     1.302156
	version                          0.9924

******************************** NOTE ********************************
The comments above are created mechanically, possibly without manual
checking by the sender.  As there are many people performing automatic
tests on each upload to CPAN, it is likely that you will receive
identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first
one with correction and/or additional informations, and do not take
it personally.  We appreciate your patience. :)
**********************************************************************

Additional comments:


This report was machine-generated by CPANPLUS::Dist::YACSmoke 1.06.
Powered by minismokebox version 0.68

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    NONINTERACTIVE_TESTING = 1
    PATH = /usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/script:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/cpan/bin
    PERL5LIB = /usr/home/cpan/pit/jail/icHJQkbq8W/lib/perl5:/usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/lib:/usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 83590
    PERL5_CPANPLUS_IS_VERSION = 0.9176
    PERL5_MINISMOKEBOX = 0.68
    PERL5_YACSMOKE_BASE = /usr/home/cpan/pit/thr/conf/perl-5.8.9
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_LOCAL_LIB_ROOT = /usr/home/cpan/pit/jail/icHJQkbq8W
    PERL_MB_OPT = --install_base "/usr/home/cpan/pit/jail/icHJQkbq8W"
    PERL_MM_OPT = INSTALL_BASE=/usr/home/cpan/pit/jail/icHJQkbq8W
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/local/bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /usr/home/cpan/pit/thr/perl-5.8.9/bin/perl
    UID:  $<  = 1002
    EUID: $>  = 1002
    GID:  $(  = 1002 1002
    EGID: $)  = 1002 1002


-------------------------------


--

Summary of my perl5 (revision 5 version 8 subversion 9) configuration:
  Platform:
    osname=freebsd, osvers=11.2-release-p8, archname=i386-freebsd-thread-multi
    uname='freebsd froggle 11.2-release-p8 freebsd 11.2-release-p8 #0: tue jan 8 21:31:23 utc 2019 root@amd64-builder.daemonology.net:usrobjusrsrcsysgeneric i386 '
    config_args='-des -Dprefix=/usr/home/cpan/pit/thr/perl-5.8.9 -Dusethreads'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=define use5005threads=undef useithreads=define usemultiplicity=define
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include',
    optimize='-O2',
    cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='4.2.1 Compatible FreeBSD Clang 6.0.0 (tags/RELEASE_600/final 326565)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-pthread -Wl,-E  -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lgdbm -ldl -lm -lcrypt -lutil
    perllibs=-ldl -lm -lcrypt -lutil
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC', lddlflags='-shared  -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP
                        USE_FAST_STDIO USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_REENTRANT_API
  Locally applied patches:
	Devel::PatchPerl 1.52
  Built under freebsd
  Compiled at Jan 15 2019 22:01:11
  %ENV:
    PERL5LIB="/usr/home/cpan/pit/jail/icHJQkbq8W/lib/perl5:/usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/lib:/usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="83590"
    PERL5_CPANPLUS_IS_VERSION="0.9176"
    PERL5_MINISMOKEBOX="0.68"
    PERL5_YACSMOKE_BASE="/usr/home/cpan/pit/thr/conf/perl-5.8.9"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_LOCAL_LIB_ROOT="/usr/home/cpan/pit/jail/icHJQkbq8W"
    PERL_MB_OPT="--install_base "/usr/home/cpan/pit/jail/icHJQkbq8W""
    PERL_MM_OPT="INSTALL_BASE=/usr/home/cpan/pit/jail/icHJQkbq8W"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /usr/home/cpan/pit/jail/icHJQkbq8W/lib/perl5/5.8.9/i386-freebsd-thread-multi
    /usr/home/cpan/pit/jail/icHJQkbq8W/lib/perl5/5.8.9
    /usr/home/cpan/pit/jail/icHJQkbq8W/lib/perl5/i386-freebsd-thread-multi
    /usr/home/cpan/pit/jail/icHJQkbq8W/lib/perl5
    /usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/lib
    /usr/home/cpan/pit/thr/conf/perl-5.8.9/.cpanplus/5.8.9/build/K_goOQiT1R/rdapper-0.3/blib/arch
    /usr/home/cpan/pit/thr/perl-5.8.9/lib/5.8.9/i386-freebsd-thread-multi
    /usr/home/cpan/pit/thr/perl-5.8.9/lib/5.8.9
    /usr/home/cpan/pit/thr/perl-5.8.9/lib/site_perl/5.8.9/i386-freebsd-thread-multi
    /usr/home/cpan/pit/thr/perl-5.8.9/lib/site_perl/5.8.9
    .