Ceph-Rados-Striper v0.02 Perl 5 v5.8.1 x86_64-linux

Status
Na
From
Nigel Horne
Dist
Ceph-Rados-Striper v0.02
Platform
Perl 5 v5.8.1 x86_64-linux
Date
2020-05-15T00:33:48
ID
bdf50932-9643-11ea-84b9-0e9a839084db
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Alex Bowley,

This is a computer-generated report for Ceph-Rados-Striper-0.02
on perl 5.8.1, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin/perl Makefile.PL':

Perl v5.26.1 required--this is only v5.8.1, stopped at Makefile.PL line 1.
BEGIN failed--compilation aborted at Makefile.PL line 1.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have
    ------------------- ---- ----
    ExtUtils::MakeMaker 0    7.38


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    HARNESS_OPTIONS = j3
    LANG = en_US.UTF-8
    PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin:/home/njh/src/njh/smoker/bin:/usr/bin:/bin
    PERL = /home/njh/perl5/perlbrew/perls/perl-5.8.1/bin/perl
    PERL5LIB = 
    PERL5OPT = -I/tmp/testwrapper.21032/CPAN-Reporter-lib-5yOd -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 21047
    PERL5_CPAN_IS_EXECUTING = /home/njh/.cpan/build/Ceph-Rados-Striper-0.02-6/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 21047
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 21029,21047
    PERLBREW_HOME = /home/njh/.perlbrew
    PERLBREW_MANPATH = /home/njh/perl5/perlbrew/perls/perl-5.8.1/man
    PERLBREW_PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin
    PERLBREW_PERL = perl-5.8.1
    PERLBREW_ROOT = /home/njh/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.88
    PERLBREW_VERSION = 0.88
    PERL_AUTOINSTALL = --defaultdeps
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/bin/bash
    TMPDIR = /tmp/testwrapper.21032

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/njh/perl5/perlbrew/perls/perl-5.8.1/bin/perl
    $UID/$EUID = 1000 / 1000
    $GID = 1000 1000
    $EGID = 1000 1000

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.27    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280231
    ExtUtils::Command   7.38    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.38    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.35    
    File::Spec          3.75    
    JSON                4.02    
    JSON::PP            4.04    
    Module::Build       0.4229  
    Module::Signature   0.83    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302170
    YAML                1.30    
    YAML::Syck          1.31    
    version             0.9924  


--

Summary of my perl5 (revision 5.0 version 8 subversion 1) configuration:
  Platform:
    osname=linux, osvers=4.18.0-80.el8.x86_64, archname=x86_64-linux
    uname='linux smoker01 4.18.0-80.el8.x86_64 #1 smp tue jun 4 09:19:46 utc 2019 x86_64 x86_64 x86_64 gnulinux '
    config_args='-de -Dprefix=/home/njh/perl5/perlbrew/perls/perl-5.8.1 -Aeval:scriptdir=/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fwrapv -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fwrapv -fno-strict-aliasing -I/usr/local/include'
    ccversion='', gccversion='8.2.1 20180905 (Red Hat 8.2.1-3)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib/../lib64 /usr/lib/../lib64 /lib /usr/lib
    libs=-ldl -lm -lcrypt -lutil -lc
    perllibs=-ldl -lm -lcrypt -lutil -lc
    libc=libc-2.28.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.28'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: USE_64_BIT_INT USE_64_BIT_ALL USE_LARGE_FILES
  Locally applied patches:
  	Devel::PatchPerl 1.80
  Built under linux
  Compiled at Dec  7 2019 13:04:43
  %ENV:
    PERL="/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin/perl"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="21047"
    PERL5_CPAN_IS_EXECUTING="/home/njh/.cpan/build/Ceph-Rados-Striper-0.02-6/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="21047"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="21029,21047"
    PERLBREW_HOME="/home/njh/.perlbrew"
    PERLBREW_MANPATH="/home/njh/perl5/perlbrew/perls/perl-5.8.1/man"
    PERLBREW_PATH="/home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin"
    PERLBREW_PERL="perl-5.8.1"
    PERLBREW_ROOT="/home/njh/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.88"
    PERLBREW_VERSION="0.88"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/5.8.1/x86_64-linux
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/5.8.1
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/site_perl/5.8.1/x86_64-linux
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/site_perl/5.8.1
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/site_perl
    .