rdapper v0.3 Perl 5 v5.24.0 x86_64-linux-thread-multi

Status
Unknown
From
David Cantrell (DCANTRELL)
Dist
rdapper v0.3
Platform
Perl 5 v5.24.0 x86_64-linux-thread-multi
Date
2019-01-17T16:48:18
ID
b0f9c48c-1a77-11e9-8b48-f7337347484a
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Gavin Brown,

This is a computer-generated report for rdapper-0.3
on perl 5.24.0, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  However, attempting to
test your distribution gave an inconclusive result.

This could be because your distribution had an error during the make/build
stage, did not define tests, tests could not be found, because your tests were
interrupted before they finished, or because the results of the tests could not
be parsed.  You may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

No tests defined for rdapper extension.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module              Need Have     
    ------------------- ---- ---------
    Getopt::Long        0    2.48     
    JSON                0    4.00     
    List::MoreUtils     0    0.428    
    Net::ASN            0    1.07     
    Net::DNS::Domain    0    1698     
    Net::IP             0    1.26     
    Net::RDAP           0    0.13     
    Pod::Usage          0    1.68     
    Term::ANSIColor     0    4.04     
    Text::Wrap          0    2013.0523
    URI                 0    1.71     

build_requires:

    Module              Need Have     
    ------------------- ---- ---------
    ExtUtils::MakeMaker 0    7.10_01  

configure_requires:

    Module              Need Have     
    ------------------- ---- ---------
    ExtUtils::MakeMaker 0    7.10_01  


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    NONINTERACTIVE_TESTING = 1
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
    PERL = 5.24.0
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 30250
    PERL5_CPAN_IS_RUNNING = 30250
    PERLVER = 5.24.0
    PERL_INLINE_DIRECTORY = /home/david/.Inline-5.24.0
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 0
    SHELL = /bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/david/cpantesting/perl-5.24.0/bin/perl
    $UID/$EUID = 1000 / 1000
    $GID = 1000 1000
    $EGID = 1000 1000

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.11    
    CPAN::Meta          2.150005
    Cwd                 3.63    
    ExtUtils::CBuilder  0.280225
    ExtUtils::Command   7.10    
    ExtUtils::Install   2.04    
    ExtUtils::MakeMaker 7.10_01 
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.31    
    File::Spec          3.63    
    JSON                4.00    
    JSON::PP            2.27300 
    Module::Build       0.4224  
    Module::Signature   n/a     
    Parse::CPAN::Meta   1.4417  
    Test::Harness       3.36    
    Test::More          1.302156
    YAML                1.18    
    YAML::Syck          1.31    
    version             0.9916  


--

Summary of my perl5 (revision 5 version 24 subversion 0) configuration:
   
  Platform:
    osname=linux, osvers=3.16.0-4-amd64, archname=x86_64-linux-thread-multi
    uname='linux pigsty.barnyard.co.uk 3.16.0-4-amd64 #1 smp debian 3.16.36-1+deb8u1 (2016-09-03) x86_64 gnulinux '
    config_args='-de -Duse64bitall -Dusethreads -Dprefix=/home/david/cpantesting/perl-5.24.0'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2',
    optimize='-O2',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion='', gccversion='4.9.2', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678, doublekind=3
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16, longdblkind=3
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
    libs=-lpthread -lnsl -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.19.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.19'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES MULTIPLICITY PERLIO_LAYERS
                        PERL_COPY_ON_WRITE PERL_DONT_CREATE_GVSV
                        PERL_HASH_FUNC_ONE_AT_A_TIME_HARD
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV USE_64_BIT_ALL USE_64_BIT_INT
                        USE_ITHREADS USE_LARGE_FILES USE_LOCALE
                        USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_LOCALE_TIME USE_PERLIO
                        USE_PERL_ATOF USE_REENTRANT_API
  Locally applied patches:
	Devel::PatchPerl 1.44
  Built under linux
  Compiled at Oct 12 2016 16:54:26
  %ENV:
    PERL="5.24.0"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="30250"
    PERL5_CPAN_IS_RUNNING="30250"
    PERLVER="5.24.0"
    PERL_INLINE_DIRECTORY="/home/david/.Inline-5.24.0"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="0"
  @INC:
    /home/david/cpantesting/perl-5.24.0/lib/site_perl/5.24.0/x86_64-linux-thread-multi
    /home/david/cpantesting/perl-5.24.0/lib/site_perl/5.24.0
    /home/david/cpantesting/perl-5.24.0/lib/5.24.0/x86_64-linux-thread-multi
    /home/david/cpantesting/perl-5.24.0/lib/5.24.0
    .