Alien-CSFML vv0.0.7 Perl 5 v5.18.4 x86_64-linux

Status
Na
From
Slaven Rezić
Dist
Alien-CSFML vv0.0.7
Platform
Perl 5 v5.18.4 x86_64-linux
Date
2022-10-22T03:27:53
ID
83ba9ae6-51b9-11ed-9a50-ae4f6e8775ea
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Sanko Robinson,

This is a computer-generated report for Alien-CSFML-v0.0.7
on perl 5.18.4, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/opt/perl-5.18.4/bin/perl Build.PL':

Creating new 'Build' script for 'Alien-CSFML' version 'v0.0.7'

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module                 Need     Have    
    ---------------------- -------- --------
    File::ShareDir         0        1.118   
    File::Slurp            0        9999.32 
    File::Spec::Functions  0        3.75    
    JSON::Tiny             0        0.58    
  ! perl                   5.026000 5.018004

build_requires:

    Module                 Need     Have    
    ---------------------- -------- --------
    Alien::cmake3          0        0.08    
  ! Alien::git             0        n/a     
    Archive::Extract       0        0.88    
    File::Copy             0        2.26    
    File::Copy::Recursive  0        0.45    
    File::pushd            0        1.016   
    File::ShareDir         0        1.118   
    File::Slurp            0        9999.32 
    File::Spec::Functions  0        3.75    
    HTTP::Tiny             0        0.082   
    JSON::Tiny             0        0.58    
    Test::More             0.98     1.302191

configure_requires:

    Module                 Need     Have    
    ---------------------- -------- --------
    Archive::Extract       0        0.88    
    CPAN::Meta             0        2.150010
    Devel::CheckBin        0        0.04    
    Exporter               5.57     5.74    
    ExtUtils::CBuilder     0        0.280236
    ExtUtils::Config       0.003    0.008   
    ExtUtils::Helpers      0.020    0.026   
    ExtUtils::Install      0        2.06    
    ExtUtils::InstallPaths 0.002    0.012   
    ExtUtils::ParseXS      0        3.44    
    File::Basename         0        2.84    
    File::Copy             0        2.26    
    File::Copy::Recursive  0        0.45    
    File::Find             0        1.23    
    File::Path             0        2.18    
    File::pushd            0        1.016   
    File::ShareDir         0        1.118   
    File::Slurp            0        9999.32 
    File::Spec::Functions  0        3.75    
    Getopt::Long           0        2.52    
    HTTP::Tiny             0        0.082   
    JSON::Tiny             0        0.58    
    Module::Build::Tiny    0.035    0.039   
    Pod::Man               0        2.27    
    TAP::Harness           0        3.44    


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LANG = en_US.UTF-8
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cpansand/bin/linux-gnu:/home/cpansand/bin/sh:/home/cpansand/bin:/usr/games:/home/cpansand/devel:/home/eserte/src/srezic-misc/scripts
    PERL = /opt/perl-5.18.4/bin/perl
    PERL5LIB = /home/cpansand/.cpan/build/2022102203/JSON-Tiny-0.58-3/blib/arch:/home/cpansand/.cpan/build/2022102203/JSON-Tiny-0.58-3/blib/lib
    PERL5OPT = -I/var/tmp/cpansmoker-1023/2022102203/CPAN-Reporter-lib-TqQX -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 2935
    PERL5_CPAN_IS_EXECUTING = 
    PERL5_CPAN_IS_RUNNING = 2935
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 32672,2935
    PERLDOC = -MPod::Perldoc::ToTextOverstrike
    PERL_AUTOINSTALL = --defaultdeps
    PERL_BATCH = yes
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_CPAN_REPORTER_CONFIG = /var/tmp/cpansmoker-1023/2022102203/cpanreporter_000_config.ini
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/bin/zsh
    TERM = screen
    TMPDIR = /var/tmp/cpansmoker-1023/2022102203

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /opt/perl-5.18.4/bin/perl
    $UID/$EUID = 1023 / 1023
    $GID = 1023 1023
    $EGID = 1023 1023

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.34    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280236
    ExtUtils::Command   7.64    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.64    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.44    
    File::Spec          3.75    
    JSON                4.10    
    JSON::PP            4.12    
    Module::Build       0.4231  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.44    
    Test::More          1.302191
    YAML                1.30    
    YAML::Syck          1.34    
    version             0.9929  


--

Summary of my perl5 (revision 5 version 18 subversion 4) configuration:
   
  Platform:
    osname=linux, osvers=3.10.0-1160.76.1.el7.x86_64, archname=x86_64-linux
    uname='linux cloud3.bbbike.org 3.10.0-1160.76.1.el7.x86_64 #1 smp wed aug 10 16:21:17 utc 2022 x86_64 x86_64 x86_64 gnulinux '
    config_args='-ds -e -Dprefix=/opt/perl-5.18.4 -Dcf_email=srezic@cpan.org'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.8.5 20150623 (Red Hat 4.8.5-44)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib/../lib64 /usr/lib/../lib64 /lib /usr/lib /lib64 /usr/lib64 /usr/local/lib64
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.17.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.17'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES PERLIO_LAYERS PERL_DONT_CREATE_GVSV
                        PERL_HASH_FUNC_ONE_AT_A_TIME_HARD PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV PERL_SAWAMPERSAND USE_64_BIT_ALL
                        USE_64_BIT_INT USE_LARGE_FILES USE_LOCALE
                        USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF
  Locally applied patches:
	Devel::PatchPerl 2.08
  Built under linux
  Compiled at Sep 24 2022 07:25:39
  %ENV:
    PERL="/opt/perl-5.18.4/bin/perl"
    PERL5LIB="/home/cpansand/.cpan/build/2022102203/JSON-Tiny-0.58-3/blib/arch:/home/cpansand/.cpan/build/2022102203/JSON-Tiny-0.58-3/blib/lib"
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="2935"
    PERL5_CPAN_IS_EXECUTING=""
    PERL5_CPAN_IS_RUNNING="2935"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="32672,2935"
    PERLDOC="-MPod::Perldoc::ToTextOverstrike"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_BATCH="yes"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_CPAN_REPORTER_CONFIG="/var/tmp/cpansmoker-1023/2022102203/cpanreporter_000_config.ini"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /home/cpansand/.cpan/build/2022102203/JSON-Tiny-0.58-3/blib/arch
    /home/cpansand/.cpan/build/2022102203/JSON-Tiny-0.58-3/blib/lib
    /opt/perl-5.18.4/lib/site_perl/5.18.4/x86_64-linux
    /opt/perl-5.18.4/lib/site_perl/5.18.4
    /opt/perl-5.18.4/lib/5.18.4/x86_64-linux
    /opt/perl-5.18.4/lib/5.18.4
    .