CXC-Form-Tiny-OptArgs2 v0.01 Perl 5 v5.39.3 darwin-2level

Status
Fail
From
David Cantrell (DCANTRELL)
Dist
CXC-Form-Tiny-OptArgs2 v0.01
Platform
Perl 5 v5.39.3 darwin-2level
Date
2023-09-17T00:02:24
ID
7b1260b2-54ed-11ee-8cee-baf243fcbcee
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Diab Jerius,

This is a computer-generated report for CXC-Form-Tiny-OptArgs2-0.01
on perl 5.39.3, created by CPAN-Reporter-1.2019.

Thank you for uploading your work to CPAN.  However, there was a problem
testing your distribution.

If you think this report is invalid, please consult the CPAN Testers Wiki
for suggestions on how to avoid getting FAIL reports for missing library
or binary dependencies, unsupported operating systems, and so on:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from './Build test':

t/00-compile.t ......... ok
# 
# Versions for all modules listed in MYMETA.json (including optional ones):
# 
# === Configure Requires ===
# 
#     Module               Want  Have
#     ------------------- ----- -----
#     Module::Build::Tiny 0.034 0.046
# 
# === Test Requires ===
# 
#     Module              Want     Have
#     ------------------- ---- --------
#     ExtUtils::MakeMaker  any     7.70
#     File::Spec           any     3.90
#     Form::Tiny           any     2.21
#     IO::Handle           any     1.53
#     IPC::Open3           any     1.22
#     Package::Variant     any 1.003002
#     Test2::V0            any 0.000156
#     Test::Lib            any    0.003
#     Test::More           any 1.302195
#     Types::Standard      any 2.004000
#     aliased              any     0.34
#     base                 any     2.27
# 
# === Test Recommends ===
# 
#     Module         Want     Have
#     ---------- -------- --------
#     CPAN::Meta 2.120900 2.150010
# 
# === Runtime Requires ===
# 
#     Module              Want     Have
#     ---------------- ------- --------
#     Carp                 any     1.54
#     Class::Load          any     0.25
#     Data::Dump           any     1.25
#     Hash::Fold           any   v1.0.0
#     Hash::Merge          any    0.302
#     List::Util           any     1.63
#     Log::Any             any    1.717
#     OptArgs2             any    2.0.0
#     Ref::Util            any    0.204
#     Scalar::Util         any     1.63
#     experimental         any    0.031
#     namespace::clean     any     0.27
#     perl             v5.26.0 5.039003
#     strict               any     1.13
#     warnings             any     1.67
# 
t/00-report-prereqs.t .. ok
could not load plugin CXC::Form::Tiny::Plugin::OptArgs2: Can't locate CXC/Form/Tiny/Plugin/OptArgs2.pm in @INC (you may need to install the CXC::Form::Tiny::Plugin::OptArgs2 module) (@INC entries checked: /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/t/lib /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/blib/arch /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/blib/lib /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3/darwin-2level /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3 /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3/darwin-2level /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3) at (eval 187) line 1.
BEGIN failed--compilation aborted at (eval 187) line 1.
 at t/config.t line 8.
BEGIN failed--compilation aborted at t/config.t line 8.
t/config.t ............. 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
could not load plugin CXC::Form::Tiny::Plugin::OptArgs2: Can't locate CXC/Form/Tiny/Plugin/OptArgs2.pm in @INC (you may need to install the CXC::Form::Tiny::Plugin::OptArgs2 module) (@INC entries checked: /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/t/lib /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/blib/arch /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/blib/lib /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3/darwin-2level /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3 /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3/darwin-2level /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3) at (eval 195) line 1.
BEGIN failed--compilation aborted at (eval 195) line 1.
 at (eval 192) line 2.
BEGIN failed--compilation aborted at (eval 191) line 1.
t/nested.t ............. 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 
could not load plugin CXC::Form::Tiny::Plugin::OptArgs2: Can't locate CXC/Form/Tiny/Plugin/OptArgs2.pm in @INC (you may need to install the CXC::Form::Tiny::Plugin::OptArgs2 module) (@INC entries checked: /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/t/lib /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/blib/arch /Users/cpantesting/cpantesting/perl-blead/.cpan/build/CXC-Form-Tiny-OptArgs2-0.01-0/blib/lib /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3/darwin-2level /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3 /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3/darwin-2level /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3) at (eval 187) line 1.
BEGIN failed--compilation aborted at (eval 187) line 1.
 at t/simple.t line 8.
BEGIN failed--compilation aborted at t/simple.t line 8.
t/simple.t ............. 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 

Test Summary Report
-------------------
t/config.t           (Wstat: 512 (exited 2) Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/nested.t           (Wstat: 512 (exited 2) Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
t/simple.t           (Wstat: 512 (exited 2) Tests: 0 Failed: 0)
  Non-zero exit status: 2
  Parse errors: No plan found in TAP output
Files=5, Tests=2,  2 wallclock secs ( 0.05 usr  0.02 sys +  1.66 cusr  0.25 csys =  1.98 CPU)
Result: FAIL

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module              Need     Have    
    ------------------- -------- --------
    Carp                0        1.54    
    Class::Load         0        0.25    
    Data::Dump          0        1.25    
    experimental        0        0.031   
    Hash::Fold          0        v1.0.0  
    Hash::Merge         0        0.302   
    List::Util          0        1.63    
    Log::Any            0        1.717   
    namespace::clean    0        0.27    
    OptArgs2            0        2.0.0   
    perl                v5.26.0  5.039003
    Ref::Util           0        0.204   
    Scalar::Util        0        1.63    
    strict              0        1.13    
    warnings            0        1.67    

build_requires:

    Module              Need     Have    
    ------------------- -------- --------
    aliased             0        0.34    
    base                0        2.27    
    ExtUtils::MakeMaker 0        7.70    
    File::Spec          0        3.90    
    Form::Tiny          0        2.21    
    IO::Handle          0        1.53    
    IPC::Open3          0        1.22    
    Package::Variant    0        1.003002
    Test2::V0           0        0.000156
    Test::Lib           0        0.003   
    Test::More          0        1.302195
    Types::Standard     0        2.004000

configure_requires:

    Module              Need     Have    
    ------------------- -------- --------
    Module::Build::Tiny 0.034    0.046   

opt_build_requires:

    Module              Need     Have    
    ------------------- -------- --------
    CPAN::Meta          2.120900 2.150010


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    NONINTERACTIVE_TESTING = 1
    PATH = /Users/cpantesting/perl5/perlbrew/bin:/Users/cpantesting/perl5/perlbrew/perls/perl-5.32.0/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/Apple/usr/bin:/Users/cpantesting/.cargo/bin
    PERL = blead
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 8032
    PERL5_CPAN_IS_RUNNING = 8032
    PERLBREW_HOME = /Users/cpantesting/.perlbrew
    PERLBREW_MANPATH = /Users/cpantesting/perl5/perlbrew/perls/perl-5.32.0/man
    PERLBREW_PATH = /Users/cpantesting/perl5/perlbrew/bin:/Users/cpantesting/perl5/perlbrew/perls/perl-5.32.0/bin
    PERLBREW_PERL = perl-5.32.0
    PERLBREW_ROOT = /Users/cpantesting/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.94
    PERLBREW_VERSION = 0.94
    PERLVER = blead
    PERL_INLINE_DIRECTORY = /Users/cpantesting/.Inline-blead
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 0
    SHELL = /bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /Users/cpantesting/cpantesting/perl-blead/bin/perl5.39.3
    $UID/$EUID = 503 / 503
    $GID = 20 20 12 61 703 702 701 100
    $EGID = 20 20 12 61 703 702 701 100

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.36    
    CPAN::Meta          2.150010
    Cwd                 3.90    
    ExtUtils::CBuilder  0.280240
    ExtUtils::Command   7.70    
    ExtUtils::Install   2.22    
    ExtUtils::MakeMaker 7.70    
    ExtUtils::Manifest  1.75    
    ExtUtils::ParseXS   3.51    
    File::Spec          3.90    
    JSON                n/a     
    JSON::PP            4.16    
    Module::Build       0.4234  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test2               1.302195
    Test::Harness       3.47    
    Test::More          1.302195
    YAML                n/a     
    YAML::Syck          n/a     
    version             0.9929  


--

Summary of my perl5 (revision 5 version 39 subversion 3) configuration:
  Commit id: e178360011ceea4ed9cf55d21a3429855e5e99c8
  Platform:
    osname=darwin
    osvers=21.6.0
    archname=darwin-2level
    uname='darwin harrow.local 21.6.0 darwin kernel version 21.6.0: mon aug 22 20:17:10 pdt 2022; root:xnu-8020.140.49~2release_x86_64 x86_64 '
    config_args='-de -Dprefix=/Users/cpantesting/cpantesting/perl-blead -Dusedevel'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
  Compiler:
    cc='cc'
    ccflags ='-fno-common -DPERL_DARWIN -mmacosx-version-min=12.6 -DNO_THREAD_SAFE_QUERYLOCALE -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    optimize='-O3'
    cppflags='-fno-common -DPERL_DARWIN -mmacosx-version-min=12.6 -DNO_THREAD_SAFE_QUERYLOCALE -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='Apple LLVM 14.0.0 (clang-1400.0.29.202)'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags =' -mmacosx-version-min=12.6 -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/clang/14.0.0/lib /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib /usr/lib
    libs=-lgdbm
    perllibs=
    libc=
    so=dylib
    useshrplib=false
    libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=bundle
    d_dlsymun=undef
    ccdlflags=' '
    cccdlflags=' '
    lddlflags=' -mmacosx-version-min=12.6 -bundle -undefined dynamic_lookup -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_LONG_DOUBLE
    HAS_STRTOLD
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_HASH_FUNC_SIPHASH13
    PERL_HASH_USE_SBOX32
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    PERL_USE_DEVEL
    PERL_USE_SAFE_PUTENV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Built under darwin
  Compiled at Sep 15 2023 11:17:57
  %ENV:
    PERL="blead"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="8032"
    PERL5_CPAN_IS_RUNNING="8032"
    PERLBREW_HOME="/Users/cpantesting/.perlbrew"
    PERLBREW_MANPATH="/Users/cpantesting/perl5/perlbrew/perls/perl-5.32.0/man"
    PERLBREW_PATH="/Users/cpantesting/perl5/perlbrew/bin:/Users/cpantesting/perl5/perlbrew/perls/perl-5.32.0/bin"
    PERLBREW_PERL="perl-5.32.0"
    PERLBREW_ROOT="/Users/cpantesting/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.94"
    PERLBREW_VERSION="0.94"
    PERLVER="blead"
    PERL_INLINE_DIRECTORY="/Users/cpantesting/.Inline-blead"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="0"
  @INC:
    /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3/darwin-2level
    /Users/cpantesting/cpantesting/perl-blead/lib/site_perl/5.39.3
    /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3/darwin-2level
    /Users/cpantesting/cpantesting/perl-blead/lib/5.39.3