rdapper v0.3 Perl 5 v5.12.4 i686-linux-64int

Status
Pass
From
Chris Williams (BINGOS)
Dist
rdapper v0.3
Platform
Perl 5 v5.12.4 i686-linux-64int
Date
2019-01-21T09:39:13
ID
697ed17e-1d60-11e9-98d5-bb14e5798fec
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear GBROWN,

This is a computer-generated error report created automatically by
CPANPLUS, version 0.9176. Testers personal comments may appear
at the end of this report.


Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

TEST RESULTS:

Below is the error stack from stage 'fetch':

No tests defined for rdapper extension.


PREREQUISITES:

Here is a list of prerequisites you specified and versions we
managed to load:

	  Module Name                        Have     Want
	  ExtUtils::MakeMaker                7.34        0
	  Getopt::Long                       2.38        0
	  JSON                               4.01        0
	  List::MoreUtils                   0.428        0
	  Net::ASN                           1.07        0
	  Net::DNS::Domain                   1698        0
	  Net::IP                            1.26        0
	  Net::RDAP                          0.13        0
	  Pod::Usage                         1.36        0
	  Term::ANSIColor                    2.02        0
	  Text::Wrap                     2009.0305        0
	  URI                                1.76        0

Perl module toolchain versions installed:
	Module Name                        Have
	CPANPLUS                         0.9176
	CPANPLUS::Dist::Build              0.90
	Cwd                                3.75
	ExtUtils::CBuilder             0.280230
	ExtUtils::Command                  7.34
	ExtUtils::Install                  2.14
	ExtUtils::MakeMaker                7.34
	ExtUtils::Manifest                 1.71
	ExtUtils::ParseXS                  3.35
	File::Spec                         3.75
	Module::Build                    0.4224
	Pod::Parser                        1.37
	Pod::Simple                        3.14
	Test2                          1.302160
	Test::Harness                      3.42
	Test::More                     1.302160
	version                          0.9924

******************************** NOTE ********************************
The comments above are created mechanically, possibly without manual
checking by the sender.  As there are many people performing automatic
tests on each upload to CPAN, it is likely that you will receive
identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first
one with correction and/or additional informations, and do not take
it personally.  We appreciate your patience. :)
**********************************************************************

Additional comments:


This report was machine-generated by CPANPLUS::Dist::YACSmoke 1.06.
Powered by minismokebox version 0.68

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_GB.UTF-8
    LANGUAGE = en_GB:en
    NONINTERACTIVE_TESTING = 1
    PATH = /home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/script:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
    PERL5LIB = /home/cpan/pit/jail/XowavlRiWv/lib/perl5:/home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/lib:/home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 5749
    PERL5_CPANPLUS_IS_VERSION = 0.9176
    PERL5_MINISMOKEBOX = 0.68
    PERL5_YACSMOKE_BASE = /home/cpan/pit/64bit/conf/perl-5.12.4
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_LOCAL_LIB_ROOT = /home/cpan/pit/jail/XowavlRiWv
    PERL_MB_OPT = --install_base "/home/cpan/pit/jail/XowavlRiWv"
    PERL_MM_OPT = INSTALL_BASE=/home/cpan/pit/jail/XowavlRiWv
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /home/cpan/pit/64bit/perl-5.12.4/bin/perl
    UID:  $<  = 1001
    EUID: $>  = 1001
    GID:  $(  = 1001 1001
    EGID: $)  = 1001 1001


-------------------------------


--

Summary of my perl5 (revision 5 version 12 subversion 4) configuration:
   
  Platform:
    osname=linux, osvers=4.16.0-1-686, archname=i686-linux-64int
    uname='linux dodo 4.16.0-1-686 #1 smp debian 4.16.5-1 (2018-04-29) i686 gnulinux '
    config_args='-des -Dprefix=/home/cpan/pit/64bit/perl-5.12.4 -Duse64bitint'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='7.3.0', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib/i386-linux-gnu /lib/../lib /usr/lib/i386-linux-gnu /usr/lib/../lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.27.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.27'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_INT
                        USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF
  Locally applied patches:
	Devel::PatchPerl 1.48
  Built under linux
  Compiled at May 15 2018 01:56:53
  %ENV:
    PERL5LIB="/home/cpan/pit/jail/XowavlRiWv/lib/perl5:/home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/lib:/home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="5749"
    PERL5_CPANPLUS_IS_VERSION="0.9176"
    PERL5_MINISMOKEBOX="0.68"
    PERL5_YACSMOKE_BASE="/home/cpan/pit/64bit/conf/perl-5.12.4"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_LOCAL_LIB_ROOT="/home/cpan/pit/jail/XowavlRiWv"
    PERL_MB_OPT="--install_base "/home/cpan/pit/jail/XowavlRiWv""
    PERL_MM_OPT="INSTALL_BASE=/home/cpan/pit/jail/XowavlRiWv"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/pit/jail/XowavlRiWv/lib/perl5/5.12.4/i686-linux-64int
    /home/cpan/pit/jail/XowavlRiWv/lib/perl5/5.12.4
    /home/cpan/pit/jail/XowavlRiWv/lib/perl5/i686-linux-64int
    /home/cpan/pit/jail/XowavlRiWv/lib/perl5
    /home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/lib
    /home/cpan/pit/64bit/conf/perl-5.12.4/.cpanplus/5.12.4/build/uhAKpoYtXm/rdapper-0.3/blib/arch
    /home/cpan/pit/64bit/perl-5.12.4/lib/site_perl/5.12.4/i686-linux-64int
    /home/cpan/pit/64bit/perl-5.12.4/lib/site_perl/5.12.4
    /home/cpan/pit/64bit/perl-5.12.4/lib/5.12.4/i686-linux-64int
    /home/cpan/pit/64bit/perl-5.12.4/lib/5.12.4
    .