GStreamer-GConf v0.02 Perl 5 v5.20.2 armv7l-linux

Status
Unknown
From
Nigel Horne
Dist
GStreamer-GConf v0.02
Platform
Perl 5 v5.20.2 armv7l-linux
Date
2021-01-07T02:36:44
ID
2e9a011c-5091-11eb-b9db-b6c7a8faccfa
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Brian Manning,

This is a computer-generated report for GStreamer-GConf-0.02
on perl 5.20.2, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  However, attempting to
test your distribution gave an inconclusive result.

This could be because your distribution had an error during the make/build
stage, did not define tests, tests could not be found, because your tests were
interrupted before they finished, or because the results of the tests could not
be parsed.  You may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin/perl5.20.2 Makefile.PL':

Can't locate ExtUtils/Depends.pm in @INC (you may need to install the ExtUtils::Depends module) (@INC contains: /tmp/testwrapper.6900/CPAN-Reporter-lib-kT6x /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/site_perl/5.20.2/armv7l-linux /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/site_perl/5.20.2 /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/5.20.2/armv7l-linux /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/5.20.2 .) at (eval 8) line 1.
BEGIN failed--compilation aborted at (eval 8) line 1.

Checking if your kit is complete...
Looks good
MakeMaker FATAL: prerequisites not found.
    ExtUtils::Depends not installed
    ExtUtils::PkgConfig not installed
    GStreamer not installed

Please install these modules first and rerun 'perl Makefile.PL'.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have
    ------------------- ---- ----
    ExtUtils::MakeMaker 0    7.44


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    HARNESS_OPTIONS = j4
    NONINTERACTIVE_TESTING = 1
    PATH = /home/smoker/perl5/perlbrew/bin:/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    PERL = /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin/perl5.20.2
    PERL5LIB = 
    PERL5OPT = -I/tmp/testwrapper.6900/CPAN-Reporter-lib-kT6x -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 6911
    PERL5_CPAN_IS_EXECUTING = /tmp/build/GStreamer-GConf-0.02-0/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 6911
    PERLBREW_HOME = /home/smoker/.perlbrew
    PERLBREW_MANPATH = /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/man
    PERLBREW_PATH = /home/smoker/perl5/perlbrew/bin:/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin
    PERLBREW_PERL = perl-5.20.2-ld
    PERLBREW_ROOT = /home/smoker/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.88
    PERLBREW_VERSION = 0.88
    PERL_AUTOINSTALL = --defaultdeps
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /bin/bash
    TERM = xterm
    TMPDIR = /tmp/testwrapper.6900

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin/perl5.20.2
    $UID/$EUID = 1000 / 1000
    $GID = 1000
    $EGID = 1000

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.27    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280217
    ExtUtils::Command   7.44    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.44    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.24    
    File::Spec          3.75    
    JSON                4.02    
    JSON::PP            4.04    
    Module::Build       0.4231  
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302171
    YAML                1.30    
    YAML::Syck          1.32    
    version             0.9909  


--

Summary of my perl5 (revision 5 version 20 subversion 2) configuration:
   
  Platform:
    osname=linux, osvers=4.19.75-v7l+, archname=armv7l-linux
    uname='linux 2c1d99e927e1 4.19.75-v7l+ #1270 smp tue sep 24 18:51:41 bst 2019 armv7l gnulinux '
    config_args='-de -Dprefix=/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld -Dusedevel -Duselongdouble -Accflags=-O2 -pipe -Wall -Wextra -mtune=native -march=native -Aeval:scriptdir=/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=define
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-O2 -pipe -Wall -Wextra -mtune=native -march=native -fwrapv -fno-strict-aliasing -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-O2 -pipe -Wall -Wextra -mtune=native -march=native -fwrapv -fno-strict-aliasing -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='8.3.0', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=8
    ivtype='long', ivsize=4, nvtype='long double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/gcc/arm-linux-gnueabihf/8/include-fixed /usr/include/arm-linux-gnueabihf /usr/lib /lib/arm-linux-gnueabihf /lib /usr/lib/arm-linux-gnueabihf
    libs=-lnsl -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.28.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.28'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES PERLIO_LAYERS PERL_DONT_CREATE_GVSV
                        PERL_HASH_FUNC_ONE_AT_A_TIME_HARD PERL_MALLOC_WRAP
                        PERL_NEW_COPY_ON_WRITE PERL_PRESERVE_IVUV
                        PERL_USE_DEVEL USE_LARGE_FILES USE_LOCALE
                        USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_PERLIO USE_PERL_ATOF
  Locally applied patches:
	Devel::PatchPerl 1.84
  Built under linux
  Compiled at Feb  2 2020 18:06:26
  %ENV:
    PERL="/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin/perl5.20.2"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="6911"
    PERL5_CPAN_IS_EXECUTING="/tmp/build/GStreamer-GConf-0.02-0/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="6911"
    PERLBREW_HOME="/home/smoker/.perlbrew"
    PERLBREW_MANPATH="/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/man"
    PERLBREW_PATH="/home/smoker/perl5/perlbrew/bin:/home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/bin"
    PERLBREW_PERL="perl-5.20.2-ld"
    PERLBREW_ROOT="/home/smoker/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.88"
    PERLBREW_VERSION="0.88"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/site_perl/5.20.2/armv7l-linux
    /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/site_perl/5.20.2
    /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/5.20.2/armv7l-linux
    /home/smoker/perl5/perlbrew/perls/perl-5.20.2-ld/lib/5.20.2
    .