Catmandu-Z3950 v0.06 Perl 5 v5.24.4 x86_64-linux-thread-multi

Status
Pass
From
Slaven Rezić (SREZIC)
Dist
Catmandu-Z3950 v0.06
Platform
Perl 5 v5.24.4 x86_64-linux-thread-multi
Date
2019-01-08T09:02:50
ID
2cb47f0a-1324-11e9-bff1-bdeeac282a6b
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Patrick Hochstenbach,

This is a computer-generated report for Catmandu-Z3950-0.06
on perl 5.24.4, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from './Build test':

t/00-load.t ............ ok
t/01-post-load.t ....... ok
t/author-pod-syntax.t .. skipped: these tests are for testing by the author
All tests successful.
Files=3, Tests=6,  1 wallclock secs ( 0.02 usr  0.01 sys +  0.31 cusr  0.06 csys =  0.40 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module            Need                          Have    
    ----------------- ----------------------------- --------
    Catmandu          >= 0.94, != 0.9502, != 0.9503 1.09    
    Catmandu::MARC    0                             1.24    
    perl              v5.10.1                       5.024004
    ZOOM              0                             0       

build_requires:

    Module            Need                          Have    
    ----------------- ----------------------------- --------
    Module::Build     0.28                          0.4224  
    Pod::Simple::HTML 3.23                          3.32    
    Test::Deep        0                             1.128   
    Test::More        1.001003                      1.302141
    Test::Pod         0                             1.52    
    Test::Simple      1.001003                      1.302141
    XML::XPath        1.13                          1.42    

configure_requires:

    Module            Need                          Have    
    ----------------- ----------------------------- --------
    Module::Build     0.28                          0.4224  


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LANG = C
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cpansand/bin/linux-gnu:/home/cpansand/bin/sh:/home/cpansand/bin:/usr/games:/home/cpansand/devel:/home/eserte/src/srezic-misc/scripts
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 11646
    PERL5_CPAN_IS_RUNNING = 11646
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 27057,11646
    PERLDOC = -MPod::Perldoc::ToTextOverstrike
    PERL_BATCH = yes
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_CPAN_REPORTER_CONFIG = /var/tmp/cpansmoker-1023/2019010808/cpanreporter_000_config.ini
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/bin/zsh
    TERM = screen
    TMPDIR = /var/tmp/cpansmoker-1023/2019010808

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /opt/perl-5.24.4t/bin/perl
    $UID/$EUID = 1023 / 1023
    $GID = 1023 1023
    $EGID = 1023 1023

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.16    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280230
    ExtUtils::Command   7.34    
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.34    
    ExtUtils::Manifest  1.71    
    ExtUtils::ParseXS   3.31    
    File::Spec          3.75    
    JSON                4.00    
    JSON::PP            2.97001 
    Module::Build       0.4224  
    Module::Signature   0.83    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302141
    YAML                1.26    
    YAML::Syck          1.31    
    version             0.9923  


--

Summary of my perl5 (revision 5 version 24 subversion 4) configuration:
   
  Platform:
    osname=linux, osvers=3.16.0-5-amd64, archname=x86_64-linux-thread-multi
    uname='linux debian8 3.16.0-5-amd64 #1 smp debian 3.16.51-3+deb8u1 (2018-01-08) x86_64 gnulinux '
    config_args='-ds -e -Dprefix=/opt/perl-5.24.4t -Dusethreads -Dcf_email=srezic@cpan.org'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2',
    optimize='-O2',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion='', gccversion='4.9.2', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678, doublekind=3
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16, longdblkind=3
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/gcc/x86_64-linux-gnu/4.9/include-fixed /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
    libs=-lpthread -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.19.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.19'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES MULTIPLICITY PERLIO_LAYERS
                        PERL_COPY_ON_WRITE PERL_DONT_CREATE_GVSV
                        PERL_HASH_FUNC_ONE_AT_A_TIME_HARD
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV USE_64_BIT_ALL USE_64_BIT_INT
                        USE_ITHREADS USE_LARGE_FILES USE_LOCALE
                        USE_LOCALE_COLLATE USE_LOCALE_CTYPE
                        USE_LOCALE_NUMERIC USE_LOCALE_TIME USE_PERLIO
                        USE_PERL_ATOF USE_REENTRANT_API
  Built under linux
  Compiled at Apr 17 2018 04:57:43
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="11646"
    PERL5_CPAN_IS_RUNNING="11646"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="27057,11646"
    PERLDOC="-MPod::Perldoc::ToTextOverstrike"
    PERL_BATCH="yes"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_CPAN_REPORTER_CONFIG="/var/tmp/cpansmoker-1023/2019010808/cpanreporter_000_config.ini"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /opt/perl-5.24.4t/lib/site_perl/5.24.4/x86_64-linux-thread-multi
    /opt/perl-5.24.4t/lib/site_perl/5.24.4
    /opt/perl-5.24.4t/lib/5.24.4/x86_64-linux-thread-multi
    /opt/perl-5.24.4t/lib/5.24.4
    .