Regexp-Compare v0.33 Perl 5 v5.10.1 darwin-2level

Status
Na
From
Neil Bowers
Dist
Regexp-Compare v0.33
Platform
Perl 5 v5.10.1 darwin-2level
Date
2021-06-27T11:31:00
ID
262c4266-d73b-11eb-9b73-b150fc29d15d
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Vaclav Barta,

This is a computer-generated report for Regexp-Compare-0.33
on perl 5.10.1, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/local/perl/5101/bin/perl Makefile.PL':

Perl v5.30.0 required--this is only v5.10.1, stopped at Makefile.PL line 1.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have
    ------------------- ---- ----
    ExtUtils::MakeMaker 0    7.62


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    PATH = /usr/local/apache/bin:/usr/local/bin:/opt/local/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Applications/VMware Fusion.app/Contents/Public:/usr/local/go/bin:/opt/X11/bin:/usr/local/git/bin
    PERL = [undef]
    PERL5LIB = 
    PERL5OPT = -I/tmp/CPAN-Reporter-lib-rjHH -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 22059
    PERL5_CPAN_IS_EXECUTING = /var/root/.cpan/build/Regexp-Compare-0.33-tFLM42/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 22059
    PERL_AUTOINSTALL = --defaultdeps
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    SHELL = /bin/sh
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /usr/local/perl/5101/bin/perl
    $UID/$EUID = 0 / 0
    $GID = 0 0 1 2 3 4 5 8 9 12 20 29 61 80 701 702 33
    $EGID = 0 0 1 2 3 4 5 8 9 12 20 29 61 80 701 702 33

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.05    
    CPAN::Meta          2.143240
    Cwd                 3.47    
    ExtUtils::CBuilder  0.280216
    ExtUtils::Command   7.62    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.62    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.35    
    File::Spec          3.47    
    JSON                2.90    
    JSON::PP            2.27203 
    Module::Build       0.4231  
    Module::Signature   n/a     
    Parse::CPAN::Meta   1.4414  
    Test::Harness       3.32    
    Test::More          1.302177
    YAML                0.95    
    YAML::Syck          1.27    
    version             0.9929  


--

Summary of my perl5 (revision 5 version 10 subversion 1) configuration:
   
  Platform:
    osname=darwin, osvers=12.5.0, archname=darwin-2level
    uname='darwin tucumcari.local 12.5.0 darwin kernel version 12.5.0: sun sep 29 13:33:47 pdt 2013; root:xnu-2050.48.12~1release_x86_64 x86_64 '
    config_args='-Dprefix=/usr/local/perl/5101'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='gcc', ccflags ='-fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -I/opt/local/include',
    optimize='-O3',
    cppflags='-no-cpp-precomp -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -I/opt/local/include'
    ccversion='', gccversion='4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.11.00)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='env MACOSX_DEPLOYMENT_TARGET=10.3 gcc', ldflags =' -fstack-protector -L/usr/local/lib -L/opt/local/lib'
    libpth=/usr/local/lib /opt/local/lib /usr/lib
    libs=-lgdbm -ldbm -ldl -lm -lutil -lc
    perllibs=-ldl -lm -lutil -lc
    libc=, so=dylib, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=bundle, d_dlsymun=undef, ccdlflags=' '
    cccdlflags=' ', lddlflags=' -bundle -undefined dynamic_lookup -L/usr/local/lib -L/opt/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO
  Built under darwin
  Compiled at Jun 30 2014 10:43:45
  %ENV:
    PERL=""
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="22059"
    PERL5_CPAN_IS_EXECUTING="/var/root/.cpan/build/Regexp-Compare-0.33-tFLM42/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="22059"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
  @INC:
    /usr/local/perl/5101/lib/5.10.1/darwin-2level
    /usr/local/perl/5101/lib/5.10.1
    /usr/local/perl/5101/lib/site_perl/5.10.1/darwin-2level
    /usr/local/perl/5101/lib/site_perl/5.10.1
    .