Serge-Sync-Plugin-TranslationService-phraseapp v0.900.6 Perl 5 v5.22.2 x86_64-linux-thread-multi

Status
Pass
From
Chris Williams (BINGOS)
Dist
Serge-Sync-Plugin-TranslationService-phraseapp v0.900.6
Platform
Perl 5 v5.22.2 x86_64-linux-thread-multi
Date
2019-01-12T02:52:08
ID
0d85fcdc-1615-11e9-98d5-bb14e5798fec
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear DRAGOSV,

This is a computer-generated error report created automatically by
CPANPLUS, version 0.9176. Testers personal comments may appear
at the end of this report.


Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

TEST RESULTS:

Below is the error stack from stage 'make test':

PERL_DL_NONLAZY=1 "/home/cpan/pit/thr/perl-5.22.2/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/00-compile.t .. ok
t/plugins.t ..... ok
All tests successful.
Files=2, Tests=4,  0 wallclock secs ( 0.02 usr  0.00 sys +  0.21 cusr  0.03 csys =  0.26 CPU)
Result: PASS


PREREQUISITES:

Here is a list of prerequisites you specified and versions we
managed to load:

	  Module Name                        Have     Want
	  ExtUtils::MakeMaker                7.34        0
	  File::Spec                         3.75        0
	  IO::Handle                         1.35        0
	  IPC::Open3                         1.18        0
	  Serge                             1.3.2   v1.3.2
	  Test::More                     1.302141        0

Perl module toolchain versions installed:
	Module Name                        Have
	CPANPLUS                         0.9176
	CPANPLUS::Dist::Build              0.90
	Cwd                                3.75
	ExtUtils::CBuilder             0.280230
	ExtUtils::Command                  7.34
	ExtUtils::Install                  2.14
	ExtUtils::MakeMaker                7.34
	ExtUtils::Manifest                 1.71
	ExtUtils::ParseXS                  3.35
	File::Spec                         3.75
	Module::Build                    0.4224
	Pod::Parser                        1.63
	Pod::Simple                        3.29
	Test2                          1.302141
	Test::Harness                      3.42
	Test::More                     1.302141
	version                          0.9924

******************************** NOTE ********************************
The comments above are created mechanically, possibly without manual
checking by the sender.  As there are many people performing automatic
tests on each upload to CPAN, it is likely that you will receive
identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first
one with correction and/or additional informations, and do not take
it personally.  We appreciate your patience. :)
**********************************************************************

Additional comments:


This report was machine-generated by CPANPLUS::Dist::YACSmoke 1.06.
Powered by minismokebox version 0.68

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_GB.UTF-8
    LANGUAGE = en_GB:en
    NONINTERACTIVE_TESTING = 1
    PATH = /home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/script:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
    PERL5LIB = /home/cpan/pit/jail/sXqEUIn_ak/lib/perl5:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/lib:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/arch:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/X345AoVDd1/Serge-Sync-Plugin-TranslationService-phraseapp-0.900.6/blib/lib:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/X345AoVDd1/Serge-Sync-Plugin-TranslationService-phraseapp-0.900.6/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 32417
    PERL5_CPANPLUS_IS_VERSION = 0.9176
    PERL5_MINISMOKEBOX = 0.68
    PERL5_YACSMOKE_BASE = /home/cpan/pit/thr/conf/perl-5.22.2
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_LOCAL_LIB_ROOT = /home/cpan/pit/jail/sXqEUIn_ak
    PERL_MB_OPT = --install_base "/home/cpan/pit/jail/sXqEUIn_ak"
    PERL_MM_OPT = INSTALL_BASE=/home/cpan/pit/jail/sXqEUIn_ak
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /home/cpan/pit/thr/perl-5.22.2/bin/perl
    UID:  $<  = 1001
    EUID: $>  = 1001
    GID:  $(  = 1001 1001
    EGID: $)  = 1001 1001


-------------------------------


--

Summary of my perl5 (revision 5 version 22 subversion 2) configuration:
   
  Platform:
    osname=linux, osvers=4.4.0-21-generic, archname=x86_64-linux-thread-multi
    uname='linux uchder 4.4.0-21-generic #37-ubuntu smp mon apr 18 18:33:37 utc 2016 x86_64 x86_64 x86_64 gnulinux '
    config_args='-des -Dprefix=/home/cpan/pit/thr/perl-5.22.2 -Dusethreads'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion='', gccversion='5.3.1 20160413', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678, doublekind=3
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16, longdblkind=3
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/gcc/x86_64-linux-gnu/5/include-fixed /usr/include/x86_64-linux-gnu /usr/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib
    libs=-lpthread -lnsl -lgdbm -ldl -lm -lcrypt -lutil -lc -lgdbm_compat
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.23.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.23'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options: HAS_TIMES MULTIPLICITY PERLIO_LAYERS
                        PERL_DONT_CREATE_GVSV
                        PERL_HASH_FUNC_ONE_AT_A_TIME_HARD
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP
                        PERL_NEW_COPY_ON_WRITE PERL_PRESERVE_IVUV
                        USE_64_BIT_ALL USE_64_BIT_INT USE_ITHREADS
                        USE_LARGE_FILES USE_LOCALE USE_LOCALE_COLLATE
                        USE_LOCALE_CTYPE USE_LOCALE_NUMERIC USE_LOCALE_TIME
                        USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API
  Locally applied patches:
	Devel::PatchPerl 1.42
  Built under linux
  Compiled at May  2 2016 04:35:15
  %ENV:
    PERL5LIB="/home/cpan/pit/jail/sXqEUIn_ak/lib/perl5:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/lib:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/arch:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/X345AoVDd1/Serge-Sync-Plugin-TranslationService-phraseapp-0.900.6/blib/lib:/home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/X345AoVDd1/Serge-Sync-Plugin-TranslationService-phraseapp-0.900.6/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="32417"
    PERL5_CPANPLUS_IS_VERSION="0.9176"
    PERL5_MINISMOKEBOX="0.68"
    PERL5_YACSMOKE_BASE="/home/cpan/pit/thr/conf/perl-5.22.2"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_LOCAL_LIB_ROOT="/home/cpan/pit/jail/sXqEUIn_ak"
    PERL_MB_OPT="--install_base "/home/cpan/pit/jail/sXqEUIn_ak""
    PERL_MM_OPT="INSTALL_BASE=/home/cpan/pit/jail/sXqEUIn_ak"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/pit/jail/sXqEUIn_ak/lib/perl5/5.22.2/x86_64-linux-thread-multi
    /home/cpan/pit/jail/sXqEUIn_ak/lib/perl5/5.22.2
    /home/cpan/pit/jail/sXqEUIn_ak/lib/perl5/x86_64-linux-thread-multi
    /home/cpan/pit/jail/sXqEUIn_ak/lib/perl5
    /home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/lib
    /home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/0rEnHPlmUM/Serge-v1.3.2/blib/arch
    /home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/X345AoVDd1/Serge-Sync-Plugin-TranslationService-phraseapp-0.900.6/blib/lib
    /home/cpan/pit/thr/conf/perl-5.22.2/.cpanplus/5.22.2/build/X345AoVDd1/Serge-Sync-Plugin-TranslationService-phraseapp-0.900.6/blib/arch
    /home/cpan/pit/thr/perl-5.22.2/lib/site_perl/5.22.2/x86_64-linux-thread-multi
    /home/cpan/pit/thr/perl-5.22.2/lib/site_perl/5.22.2
    /home/cpan/pit/thr/perl-5.22.2/lib/5.22.2/x86_64-linux-thread-multi
    /home/cpan/pit/thr/perl-5.22.2/lib/5.22.2
    .