App-ListSoftwareLicenses v0.080 Perl 5 v5.10.0 amd64-freebsd

Status
Na
From
Bartosz Jarzyna
Dist
App-ListSoftwareLicenses v0.080
Platform
Perl 5 v5.10.0 amd64-freebsd
Date
2023-09-29T04:24:16
ID
0cec0858-5e80-11ee-af4d-40b347702ea9
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear perlancar,

This is a computer-generated report for App-ListSoftwareLicenses-0.080
on perl 5.10.0, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/home/smoker/perl5/perlbrew/perls/perl-5.10.0/bin/perl Makefile.PL':

Perl v5.10.1 required--this is only v5.10.0, stopped at Makefile.PL line 5.
BEGIN failed--compilation aborted at Makefile.PL line 5.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have
    ------------------- ---- ----
    ExtUtils::MakeMaker 0    7.64


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = C.UTF-8
    PATH = /sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/home/smoker/bin
    PERL = /home/smoker/perl5/perlbrew/perls/perl-5.10.0/bin/perl
    PERL5LIB = 
    PERL5OPT = -I/tmp/CPAN-Reporter-lib-rGxH -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 79713
    PERL5_CPAN_IS_EXECUTING = /home/smoker/.cpan/build/App-ListSoftwareLicenses-0.080-0/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 79713
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 31678,79713
    PERL_AUTOINSTALL = --defaultdeps
    PERL_CR_SMOKER_CURRENT = App-ListSoftwareLicenses-0.080
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/sh

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/smoker/perl5/perlbrew/perls/perl-5.10.0/bin/perl
    $UID/$EUID = 1001 / 1001
    $GID = 1001 1001
    $EGID = 1001 1001

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.16    
    CPAN::Meta          2.143240
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280236
    ExtUtils::Command   7.64    
    ExtUtils::Install   2.06    
    ExtUtils::MakeMaker 7.64    
    ExtUtils::Manifest  1.70    
    ExtUtils::ParseXS   3.44    
    File::Spec          3.75    
    JSON                n/a     
    JSON::PP            4.12    
    Module::Build       0.4231  
    Module::Signature   n/a     
    Parse::CPAN::Meta   1.4414  
    Test::Harness       3.44    
    Test::More          1.302191
    YAML                n/a     
    YAML::Syck          1.34    
    version             0.9929  


--

Summary of my perl5 (revision 5 version 10 subversion 0) configuration:
  Platform:
    osname=freebsd, osvers=13.1-release-p3, archname=amd64-freebsd
    uname='freebsd smoker-10.smoker 13.1-release-p3 freebsd 13.1-release-p3 generic amd64 '
    config_args='-de -Dprefix=/home/smoker/perl5/perlbrew/perls/perl-5.10.0 -Aeval:scriptdir=/home/smoker/perl5/perlbrew/perls/perl-5.10.0/bin'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include',
    optimize='-O2',
    cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='FreeBSD Clang 13.0.0 (git@github.com:llvm/llvm-project.git llvmorg-13.0.0-0-gd7b669b3a303)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-Wl,-E  -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-ldl -lm -lcrypt -lutil -lc
    perllibs=-ldl -lm -lcrypt -lutil -lc
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC', lddlflags='-shared  -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_LARGE_FILES USE_PERLIO
  Locally applied patches:
	Devel::PatchPerl 2.08
  Built under freebsd
  Compiled at Nov 16 2022 19:38:41
  %ENV:
    PERL="/home/smoker/perl5/perlbrew/perls/perl-5.10.0/bin/perl"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="79713"
    PERL5_CPAN_IS_EXECUTING="/home/smoker/.cpan/build/App-ListSoftwareLicenses-0.080-0/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="79713"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="31678,79713"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_CR_SMOKER_CURRENT="App-ListSoftwareLicenses-0.080"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/smoker/perl5/perlbrew/perls/perl-5.10.0/lib/5.10.0/amd64-freebsd
    /home/smoker/perl5/perlbrew/perls/perl-5.10.0/lib/5.10.0
    /home/smoker/perl5/perlbrew/perls/perl-5.10.0/lib/site_perl/5.10.0/amd64-freebsd
    /home/smoker/perl5/perlbrew/perls/perl-5.10.0/lib/site_perl/5.10.0
    .