App-s5pdf v0.01 Perl 5 v5.14.2 x86_64-linux

Status
Pass
From
Andreas J. K├Ânig (ANDK)
Dist
App-s5pdf v0.01
Platform
Perl 5 v5.14.2 x86_64-linux
Date
2012-02-19T15:18:40
ID
00bb1af2-5b0d-11e1-af86-46179aeef8c6
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Emmanuel Rodriguez,

This is a computer-generated report for App-s5pdf-0.01
on perl 5.14.2, created by CPAN-Reporter-1.2003.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 /home/sand/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/dummy.t .. ok
All tests successful.
Files=1, Tests=1,  0 wallclock secs ( 0.03 usr  0.00 sys +  0.02 cusr  0.00 csys =  0.05 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module              Need Have   
    ------------------- ---- -------
  ! Cairo::GObject      0    n/a    
    Cwd                 0    3.39_01
    File::Basename      0    2.82   
    Getopt::Long        0    2.3802 
    Glib                0    1.241  
  ! Gtk3                0    n/a    
  ! Gtk3::WebKit        0    n/a    
    Pod::Usage          0    1.36   
    URI                 0    1.59   

build_requires:

    Module              Need Have   
    ------------------- ---- -------
    ExtUtils::MakeMaker 0    6.63_02

configure_requires:

    Module              Need Have   
    ------------------- ---- -------
    ExtUtils::MakeMaker 0    6.63_02


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_US.UTF-8
    LANGUAGE = en_US:en
    PATH = /home/sand/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/usr/local/perl/bin:/usr/X11/bin:/sbin:/usr/sbin
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 3269
    PERL5_CPAN_IS_RUNNING = 3269
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/bin/zsh
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/sand/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65/bin/perl
    $UID/$EUID = 1005 / 1005
    $GID = 1005 1005
    $EGID = 1005 1005

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                1.9800  
    CPAN::Meta          2.120351
    Cwd                 3.39_01 
    ExtUtils::CBuilder  0.280202
    ExtUtils::Command   1.17    
    ExtUtils::Install   1.56    
    ExtUtils::MakeMaker 6.63_02 
    ExtUtils::Manifest  1.60    
    ExtUtils::ParseXS   3.15    
    File::Spec          3.39_01 
    JSON                2.53    
    JSON::PP            2.27200 
    Module::Build       0.3800  
    Module::Signature   0.68    
    Parse::CPAN::Meta   1.4401  
    Test::Harness       3.23    
    Test::More          0.98    
    YAML                0.79    
    YAML::Syck          1.20    
    version             0.95    


--

Summary of my perl5 (revision 5 version 14 subversion 2) configuration:
  Commit id: dc281e6088d189558b79a5121119b7196c8b3db0
  Platform:
    osname=linux, osvers=2.6.32-5-amd64, archname=x86_64-linux-thread-multi
    uname='linux k83 2.6.32-5-amd64 #1 smp tue jun 14 09:42:28 utc 2011 x86_64 gnulinux '
    config_args='-Dprefix=/home/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65 -Dinstallusrbinperl=n -Uversiononly -Dusedevel -des -Ui_db -Duseithreads -Uuselongdouble -DDEBUGGING=-g'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -g',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.4.5', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib/../lib /usr/lib/../lib /lib /usr/lib /lib64 /usr/lib64
    libs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=/lib/libc-2.11.2.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.11.2'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -g -L/usr/local/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP
                        PERL_PRESERVE_IVUV PERL_USE_DEVEL USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API
  Built under linux
  Compiled at Oct  5 2011 14:23:43
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="3269"
    PERL5_CPAN_IS_RUNNING="3269"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65/lib/site_perl/5.14.2/x86_64-linux-thread-multi
    /home/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65/lib/site_perl/5.14.2
    /home/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65/lib/5.14.2/x86_64-linux-thread-multi
    /home/src/perl/repoperls/installed-perls/perl/v5.14.2/ba65/lib/5.14.2
    .