Apache2-WurflSimple v0.002 Perl 5 v5.8.1 x86_64-linux

Status
Na
From
Nigel Horne
Dist
Apache2-WurflSimple v0.002
Platform
Perl 5 v5.8.1 x86_64-linux
Date
2012-12-18T14:34:16
ID
002bcd64-4920-11e2-992e-e7c00a4a7996
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Luca Passani,

This is a computer-generated report for Apache2-WurflSimple-0.002
on perl 5.8.1, created by CPAN-Reporter-1.2006.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin/perl Makefile.PL':

Perl v5.10.0 required--this is only v5.8.1, stopped at Makefile.PL line 5.
BEGIN failed--compilation aborted at Makefile.PL line 5.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need Have
    ------------------- ---- ----
    ExtUtils::MakeMaker 6.30 6.62


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_GB.UTF-8
    LANGUAGE = en_GB:en
    LD_LIBRARY_PATH = :/usr/local/lib:/usr/lib/qt-3.3/lib:/usr/X11R6/lib
    MANPATH_WITHOUT_PERLBREW = /usr/local/man:/usr/local/share/man:/usr/share/man:/usr/local/man:/home/njh/man:/usr/share/inn/man:/usr/share/perl5/man:/usr/share/tcl-8.0/man:/usr/share/tclX-8.0.4/man:/usr/share/tix-4.1/man:/usr/share/tk-8.0/man:/usr/server/doc:/usr/share/man:/opt/intel/cc/9.1.038/man
    PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin:/home/njh/perl5/perlbrew/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/njh/bin
    PATH_WITHOUT_PERLBREW = /usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/home/njh/bin
    PERL5LIB = 
    PERL5OPT = -I/tmp/CPAN-Reporter-lib-1CR6 -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 5829
    PERL5_CPAN_IS_EXECUTING = /home/njh/.cpan/build/Apache2-WurflSimple-0.002-_fsfbF/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 5829
    PERL5_MINISMOKEBOX = 0.54
    PERLBREW_BASHRC_VERSION = 0.49
    PERLBREW_HOME = /home/njh/.perlbrew
    PERLBREW_LIB = 
    PERLBREW_MANPATH = /home/njh/perl5/perlbrew/perls/perl-5.8.1/man
    PERLBREW_PATH = /home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin
    PERLBREW_PERL = perl-5.8.1
    PERLBREW_ROOT = /home/njh/perl5/perlbrew
    PERLBREW_VERSION = 0.49
    PERL_AUTOINSTALL = --defaultdeps
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_LOCAL_LIB_ROOT = 
    PERL_MB_OPT = 
    PERL_MM_OPT = 
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = linux

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/njh/perl5/perlbrew/perls/perl-5.8.1/bin/perl
    $UID/$EUID = 1000 / 1000
    $GID = 1000 1000 112 108 46 44 30 29 25 24
    $EGID = 1000 1000 112 108 46 44 30 29 25 24

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                1.9800  
    CPAN::Meta          2.120921
    Cwd                 3.33    
    ExtUtils::CBuilder  0.280205
    ExtUtils::Command   1.17    
    ExtUtils::Install   1.54    
    ExtUtils::MakeMaker 6.62    
    ExtUtils::Manifest  1.61    
    ExtUtils::ParseXS   3.15    
    File::Spec          3.33    
    JSON                2.53    
    JSON::PP            2.27200 
    Module::Build       0.4003  
    Module::Signature   0.68    
    Parse::CPAN::Meta   1.4404  
    Test::Harness       3.25    
    Test::More          0.98    
    YAML                0.84    
    YAML::Syck          1.22    
    version             0.9901  


--

Summary of my perl5 (revision 5.0 version 8 subversion 1) configuration:
  Platform:
    osname=linux, osvers=3.1.0-1-amd64, archname=x86_64-linux
    uname='linux gateway 3.1.0-1-amd64 #1 smp tue jan 10 05:01:58 utc 2012 x86_64 gnulinux '
    config_args='-de -Dprefix=/home/njh/perl5/perlbrew/perls/perl-5.8.1 -D_FORTIFY_SOURCE=2 -Accflags=-O2'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-O2 -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-O2 -fno-strict-aliasing -I/usr/local/include'
    ccversion='', gccversion='4.6.2', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib/x86_64-linux-gnu /lib/../lib /usr/lib/x86_64-linux-gnu /usr/lib/../lib /lib /usr/lib
    libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.13'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-rdynamic'
    cccdlflags='-fpic', lddlflags='-shared -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: USE_64_BIT_INT USE_64_BIT_ALL USE_LARGE_FILES
  Built under linux
  Compiled at Jan 17 2012 09:24:03
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="5829"
    PERL5_CPAN_IS_EXECUTING="/home/njh/.cpan/build/Apache2-WurflSimple-0.002-_fsfbF/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="5829"
    PERL5_MINISMOKEBOX="0.54"
    PERLBREW_BASHRC_VERSION="0.49"
    PERLBREW_HOME="/home/njh/.perlbrew"
    PERLBREW_LIB=""
    PERLBREW_MANPATH="/home/njh/perl5/perlbrew/perls/perl-5.8.1/man"
    PERLBREW_PATH="/home/njh/perl5/perlbrew/bin:/home/njh/perl5/perlbrew/perls/perl-5.8.1/bin"
    PERLBREW_PERL="perl-5.8.1"
    PERLBREW_ROOT="/home/njh/perl5/perlbrew"
    PERLBREW_VERSION="0.49"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_LOCAL_LIB_ROOT=""
    PERL_MB_OPT=""
    PERL_MM_OPT=""
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/5.8.1/x86_64-linux
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/5.8.1
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/site_perl/5.8.1/x86_64-linux
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/site_perl/5.8.1
    /home/njh/perl5/perlbrew/perls/perl-5.8.1/lib/site_perl
    .