SPVM-Net-SSLeay v0.001 Perl 5 v5.39.3 x86_64-linux-ld

Status
Pass
From
Andreas J. K├Ânig (ANDK)
Dist
SPVM-Net-SSLeay v0.001
Platform
Perl 5 v5.39.3 x86_64-linux-ld
Date
2023-09-29T02:42:09
ID
c8f168a4-5e71-11ee-9f9f-5eced2bee781
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Yuki Kimoto,

This is a computer-generated report for SPVM-Net-SSLeay-0.001
on perl 5.39.3, created by CPAN-Reporter-1.2019.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/tmp/basesmoker-reloperl-1sUE/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/*/*.t t/*/*/*.t
OpenSSL version: OpenSSL 3.0.2 15 Mar 2022
t/basic.t .. ok
All tests successful.
Files=1, Tests=2,  3 wallclock secs ( 0.02 usr  0.00 sys +  1.44 cusr  0.26 csys =  1.72 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module              Need     Have    
    ------------------- -------- --------
    SPVM                0.989036 0.989045

build_requires:

    Module              Need     Have    
    ------------------- -------- --------
    ExtUtils::MakeMaker 0        7.70    
    SPVM::IO            0.204003 0.208   
    SPVM::Mozilla::CA   0.001    0.001   

configure_requires:

    Module              Need     Have    
    ------------------- -------- --------
    SPVM                0.989036 0.989045


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_US.UTF-8
    LC_ADDRESS = de_DE.UTF-8
    LC_IDENTIFICATION = de_DE.UTF-8
    LC_MEASUREMENT = de_DE.UTF-8
    LC_MONETARY = de_DE.UTF-8
    LC_NAME = de_DE.UTF-8
    LC_NUMERIC = de_DE.UTF-8
    LC_PAPER = de_DE.UTF-8
    LC_TELEPHONE = de_DE.UTF-8
    LC_TIME = de_DE.UTF-8
    PATH = /home/sand/bin:/usr/local/bin:/usr/local/sbin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/usr/local/perl/bin:/usr/X11/bin
    PERL = /tmp/basesmoker-reloperl-1sUE/bin/perl
    PERL5LIB = /tmp/loop_over_bdir-2127-l_84Pi/NoZone-1.3-0/blib/arch:/tmp/loop_over_bdir-2127-l_84Pi/NoZone-1.3-0/blib/lib:/tmp/loop_over_bdir-2127-l_84Pi/perl-Hardware-UPS-Perl-0.43-0/blib/arch:/tmp/loop_over_bdir-2127-l_84Pi/perl-Hardware-UPS-Perl-0.43-0/blib/lib
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 2135
    PERL5_CPAN_IS_RUNNING = 2135
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/bin/zsh
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /tmp/basesmoker-reloperl-1sUE/bin/perl
    $UID/$EUID = 1005 / 1005
    $GID = 1005 1005
    $EGID = 1005 1005

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.36    
    CPAN::Meta          2.150010
    Cwd                 3.90    
    ExtUtils::CBuilder  0.280240
    ExtUtils::Command   7.70    
    ExtUtils::Install   2.22    
    ExtUtils::MakeMaker 7.70    
    ExtUtils::Manifest  1.75    
    ExtUtils::ParseXS   3.51    
    File::Spec          3.90    
    JSON                4.10    
    JSON::PP            4.16    
    Module::Build       0.4234  
    Module::Signature   0.88    
    Parse::CPAN::Meta   2.150010
    Test2               1.302195
    Test::Harness       3.47    
    Test::More          1.302195
    YAML                1.30    
    YAML::Syck          1.34    
    version             0.9930  


--

Summary of my perl5 (revision 5 version 39 subversion 3) configuration:
  Commit id: c8a2e4d1432cd1244a4e44d6bb71920b692076b7
  Platform:
    osname=linux
    osvers=6.2.0-32-generic
    archname=x86_64-linux-ld
    uname='linux k93jammy 6.2.0-32-generic #32~22.04.1-ubuntu smp preempt_dynamic fri aug 18 10:40:13 utc 2 x86_64 x86_64 x86_64 gnulinux '
    config_args='-Dprefix=/home/sand/src/perl/repoperls/installed-perls/host/k93jammy/v5.39.3/5674 -Dmyhostname=k93jammy -Dinstallusrbinperl=n -Uversiononly -Dusedevel -des -Ui_db -Dlibswanted=cl pthread socket inet nsl gdbm dbm malloc dl ld sun m crypt sec util c cposix posix ucb BSD gdbm_compat -Uuseithreads -Duselongdouble -DEBUGGING=-g'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=define
    use64bitall=define
    uselongdouble=define
    usemymalloc=n
    default_inc_excludes_dot=define
  Compiler:
    cc='cc'
    ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64'
    optimize='-O2 -g'
    cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='11.4.0'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='long double'
    nvsize=16
    Off_t='off_t'
    lseeksize=8
    alignbytes=16
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/x86_64-linux-gnu /usr/lib /usr/lib64
    libs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/x86_64-linux-gnu/libc.so.6
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version='2.35'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='-Wl,-E'
    cccdlflags='-fPIC'
    lddlflags='-shared -O2 -g -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_LONG_DOUBLE
    HAS_STRTOLD
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_HASH_FUNC_SIPHASH13
    PERL_HASH_USE_SBOX32
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    PERL_USE_DEVEL
    PERL_USE_SAFE_PUTENV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_LONG_DOUBLE
    USE_PERLIO
    USE_PERL_ATOF
  Built under linux
  Compiled at Sep 20 2023 22:23:26
  %ENV:
    PERL="/tmp/basesmoker-reloperl-1sUE/bin/perl"
    PERL5LIB="/tmp/loop_over_bdir-2127-l_84Pi/NoZone-1.3-0/blib/arch:/tmp/loop_over_bdir-2127-l_84Pi/NoZone-1.3-0/blib/lib:/tmp/loop_over_bdir-2127-l_84Pi/perl-Hardware-UPS-Perl-0.43-0/blib/arch:/tmp/loop_over_bdir-2127-l_84Pi/perl-Hardware-UPS-Perl-0.43-0/blib/lib"
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="2135"
    PERL5_CPAN_IS_RUNNING="2135"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /tmp/loop_over_bdir-2127-l_84Pi/NoZone-1.3-0/blib/arch
    /tmp/loop_over_bdir-2127-l_84Pi/NoZone-1.3-0/blib/lib
    /tmp/loop_over_bdir-2127-l_84Pi/perl-Hardware-UPS-Perl-0.43-0/blib/arch
    /tmp/loop_over_bdir-2127-l_84Pi/perl-Hardware-UPS-Perl-0.43-0/blib/lib
    /home/sand/src/perl/repoperls/installed-perls/host/k93jammy/v5.39.3/5674/lib/site_perl/5.39.3/x86_64-linux-ld
    /home/sand/src/perl/repoperls/installed-perls/host/k93jammy/v5.39.3/5674/lib/site_perl/5.39.3
    /home/sand/src/perl/repoperls/installed-perls/host/k93jammy/v5.39.3/5674/lib/5.39.3/x86_64-linux-ld
    /home/sand/src/perl/repoperls/installed-perls/host/k93jammy/v5.39.3/5674/lib/5.39.3
    .