Art-World v0.19_03 Perl 5 v5.8.9 amd64-freebsd

Status
Na
From
Slaven Rezić
Dist
Art-World v0.19_03
Platform
Perl 5 v5.8.9 amd64-freebsd
Date
2023-02-03T13:14:00
ID
9f578ab8-a3c4-11ed-ae48-f0d76d8775ea
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Sebastien Feugere,

This is a computer-generated report for Art-World-0.19_03
on perl 5.8.9, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/perl5.8.9/bin/perl Build.PL':

Perl v5.20.0 required--this is only v5.8.9, stopped at Build.PL line 2.
BEGIN failed--compilation aborted at Build.PL line 2.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module              Need  Have 
    ------------------- ----- -----
    Module::Build::Tiny 0.039 0.039


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    LC_ALL = de_DE.ISO8859-1
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cpansand/bin/freebsd9.3:/home/cpansand/bin/sh:/home/cpansand/bin:/usr/games:/home/cpansand/devel:/usr/home/eserte/src/srezic-misc/scripts
    PERL = /usr/perl5.8.9/bin/perl
    PERL5LIB = 
    PERL5OPT = -I/var/tmp/cpansmoker-1023/2023020314/CPAN-Reporter-lib-9vx_ -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 11264
    PERL5_CPAN_IS_EXECUTING = 
    PERL5_CPAN_IS_RUNNING = 11264
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 8881,11264
    PERLDOC = -MPod::Perldoc::ToTextOverstrike
    PERL_AUTOINSTALL = --defaultdeps
    PERL_BATCH = yes
    PERL_CANARY_STABILITY_NOPROMPT = 1
    PERL_CPAN_REPORTER_CONFIG = /var/tmp/cpansmoker-1023/2023020314/cpanreporter_000_config.ini
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/local/bin/zsh
    TERM = screen
    TMPDIR = /var/tmp/cpansmoker-1023/2023020314

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /usr/perl5.8.9/bin/perl
    $UID/$EUID = 1023 / 1023
    $GID = 1023 1023
    $EGID = 1023 1023

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.34    
    CPAN::Meta          2.150010
    Cwd                 3.75    
    ExtUtils::CBuilder  0.280236
    ExtUtils::Command   7.64    
    ExtUtils::Install   2.22    
    ExtUtils::MakeMaker 7.64    
    ExtUtils::Manifest  1.73    
    ExtUtils::ParseXS   3.35    
    File::Spec          3.75    
    JSON                4.10    
    JSON::PP            4.16    
    Module::Build       0.4231  
    Module::Signature   0.88    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.44    
    Test::More          1.302192
    YAML                1.30    
    YAML::Syck          1.34    
    version             0.9929  


--

Summary of my perl5 (revision 5 version 8 subversion 9) configuration:
  Platform:
    osname=freebsd, osvers=9.2-release-p4, archname=amd64-freebsd
    uname='freebsd cvrsnica-freebsd-92 9.2-release-p4 freebsd 9.2-release-p4 #0: tue apr 8 18:08:22 utc 2014 root@amd64-builder.daemonology.net:usrobjusrsrcsysgeneric amd64 '
    config_args='-ds -e -Dprefix=/usr/perl5.8.9'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=define uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include',
    optimize='-O',
    cppflags='-DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='4.2.1 20070831 patched [FreeBSD]', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags ='-Wl,-E  -L/usr/local/lib'
    libpth=/usr/lib /usr/local/lib
    libs=-lgdbm -lm -lcrypt -lutil -lc
    perllibs=-lm -lcrypt -lutil -lc
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags=' '
    cccdlflags='-DPIC -fPIC', lddlflags='-shared  -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_MALLOC_WRAP USE_64_BIT_ALL USE_64_BIT_INT
                        USE_FAST_STDIO USE_LARGE_FILES USE_PERLIO
  Built under freebsd
  Compiled at May 15 2014 22:27:57
  %ENV:
    PERL="/usr/perl5.8.9/bin/perl"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="11264"
    PERL5_CPAN_IS_EXECUTING=""
    PERL5_CPAN_IS_RUNNING="11264"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="8881,11264"
    PERLDOC="-MPod::Perldoc::ToTextOverstrike"
    PERL_AUTOINSTALL="--defaultdeps"
    PERL_BATCH="yes"
    PERL_CANARY_STABILITY_NOPROMPT="1"
    PERL_CPAN_REPORTER_CONFIG="/var/tmp/cpansmoker-1023/2023020314/cpanreporter_000_config.ini"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /usr/perl5.8.9/lib/5.8.9/amd64-freebsd
    /usr/perl5.8.9/lib/5.8.9
    /usr/perl5.8.9/lib/site_perl/5.8.9/amd64-freebsd
    /usr/perl5.8.9/lib/site_perl/5.8.9
    .