Mojolicious-Plugin-AWS-SNS v0.03 Perl 5 v5.30.0 armv6l-linux

Status
Pass
From
gregor herrmann
Dist
Mojolicious-Plugin-AWS-SNS v0.03
Platform
Perl 5 v5.30.0 armv6l-linux
Date
2019-08-27T08:56:56
ID
9f17f8d0-c8a8-11e9-8ad3-45100eb6c4d1
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Scott Wiersdorf,

This is a computer-generated report for Mojolicious-Plugin-AWS-SNS-0.03
on perl 5.30.0, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  Congratulations!
All tests were successful.

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/usr/bin/make test':

PERL_DL_NONLAZY=1 "/srv/smoker/perl5/perlbrew/perls/perl-5.30.0/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/basic.t .. ok
All tests successful.
Files=1, Tests=15, 12 wallclock secs ( 0.48 usr  0.06 sys + 10.91 cusr  0.39 csys = 11.84 CPU)
Result: PASS

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

requires:

    Module              Need  Have   
    ------------------- ----- -------
    IO::Socket::SSL     2.066 2.066  
    Mojolicious         8.23  8.23   

build_requires:

    Module              Need  Have   
    ------------------- ----- -------
    ExtUtils::MakeMaker 0     7.37_04

configure_requires:

    Module              Need  Have   
    ------------------- ----- -------
    ExtUtils::MakeMaker 0     7.37_04


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LC_CTYPE = de_AT.utf8
    LD_LIBRARY_PATH = /usr/lib/libeatmydata
    NONINTERACTIVE_TESTING = 1
    PATH = /srv/smoker/bin:/usr/lib/ccache:/srv/smoker/perl5/perlbrew/bin:/srv/smoker/perl5/perlbrew/perls/perl-5.30.0/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
    PERL5LIB = 
    PERL5OPT = 
    PERL5_CPANPLUS_IS_RUNNING = 4634
    PERL5_CPAN_IS_RUNNING = 4634
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 31918,4634
    PERLBREW_HOME = /srv/smoker/.perlbrew
    PERLBREW_MANPATH = /srv/smoker/perl5/perlbrew/perls/perl-5.30.0/man
    PERLBREW_PATH = /srv/smoker/perl5/perlbrew/bin:/srv/smoker/perl5/perlbrew/perls/perl-5.30.0/bin
    PERLBREW_PERL = perl-5.30.0
    PERLBREW_ROOT = /srv/smoker/perl5/perlbrew
    PERLBREW_SHELLRC_VERSION = 0.86
    PERLBREW_VERSION = 0.86
    PERL_CR_SMOKER_CURRENT = Mojolicious-Plugin-AWS-SNS-0.03
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /bin/bash
    TERM = screen-256color

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /srv/smoker/perl5/perlbrew/perls/perl-5.30.0/bin/perl
    $UID/$EUID = 1111 / 1111
    $GID = 65534 65534
    $EGID = 65534 65534

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.27    
    CPAN::Meta          2.150010
    Cwd                 3.78    
    ExtUtils::CBuilder  0.280231
    ExtUtils::Command   7.37_04 
    ExtUtils::Install   2.14    
    ExtUtils::MakeMaker 7.37_04 
    ExtUtils::Manifest  1.72    
    ExtUtils::ParseXS   3.40    
    File::Spec          3.78    
    JSON                4.02    
    JSON::PP            4.04    
    Module::Build       0.42_30 
    Module::Signature   n/a     
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.42    
    Test::More          1.302167
    YAML                1.29    
    YAML::Syck          1.31    
    version             0.9924  


--

Summary of my perl5 (revision 5 version 30 subversion 0) configuration:
   
  Platform:
    osname=linux
    osvers=4.9.0-6-rpi
    archname=armv6l-linux
    uname='linux smoker 4.9.0-6-rpi #1 raspbian 4.9.82-1+deb9u3+rpi2 (2018-11-09) armv6l gnulinux '
    config_args='-de -Dprefix=/srv/smoker/perl5/perlbrew/perls/perl-5.30.0 -Aeval:scriptdir=/srv/smoker/perl5/perlbrew/perls/perl-5.30.0/bin'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=undef
    usemultiplicity=undef
    use64bitint=undef
    use64bitall=undef
    uselongdouble=undef
    usemymalloc=n
    default_inc_excludes_dot=define
    bincompat5005=undef
  Compiler:
    cc='cc'
    ccflags ='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2'
    optimize='-O2'
    cppflags='-fwrapv -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='8.3.0'
    gccosandvers=''
    intsize=4
    longsize=4
    ptrsize=4
    doublesize=8
    byteorder=1234
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=8
    longdblkind=0
    ivtype='long'
    ivsize=4
    nvtype='double'
    nvsize=8
    Off_t='off_t'
    lseeksize=8
    alignbytes=8
    prototype=define
  Linker and Libraries:
    ld='cc'
    ldflags =' -fstack-protector-strong -L/usr/local/lib'
    libpth=/usr/local/lib /usr/lib/gcc/arm-linux-gnueabihf/8/include-fixed /usr/include/arm-linux-gnueabihf /usr/lib /lib/arm-linux-gnueabihf /lib /usr/lib/arm-linux-gnueabihf
    libs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    perllibs=-lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
    libc=libc-2.28.so
    so=so
    useshrplib=false
    libperl=libperl.a
    gnulibc_version='2.28'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=so
    d_dlsymun=undef
    ccdlflags='-Wl,-E'
    cccdlflags='-fPIC'
    lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_PERLIO
    USE_PERL_ATOF
  Locally applied patches:
    Devel::PatchPerl 1.38
  Built under linux
  Compiled at May 23 2019 00:05:06
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="4634"
    PERL5_CPAN_IS_RUNNING="4634"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="31918,4634"
    PERLBREW_HOME="/srv/smoker/.perlbrew"
    PERLBREW_MANPATH="/srv/smoker/perl5/perlbrew/perls/perl-5.30.0/man"
    PERLBREW_PATH="/srv/smoker/perl5/perlbrew/bin:/srv/smoker/perl5/perlbrew/perls/perl-5.30.0/bin"
    PERLBREW_PERL="perl-5.30.0"
    PERLBREW_ROOT="/srv/smoker/perl5/perlbrew"
    PERLBREW_SHELLRC_VERSION="0.86"
    PERLBREW_VERSION="0.86"
    PERL_CR_SMOKER_CURRENT="Mojolicious-Plugin-AWS-SNS-0.03"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /srv/smoker/perl5/perlbrew/perls/perl-5.30.0/lib/site_perl/5.30.0/armv6l-linux
    /srv/smoker/perl5/perlbrew/perls/perl-5.30.0/lib/site_perl/5.30.0
    /srv/smoker/perl5/perlbrew/perls/perl-5.30.0/lib/5.30.0/armv6l-linux
    /srv/smoker/perl5/perlbrew/perls/perl-5.30.0/lib/5.30.0
    .