Padre-Plugin-PAR v0.06 Perl 5 v5.12.0 i386-netbsd-64int

Status
Unknown
From
Chris Williams (BINGOS)
Dist
Padre-Plugin-PAR v0.06
Platform
Perl 5 v5.12.0 i386-netbsd-64int
Date
2010-08-14T04:22:44
ID
961411f6-a75b-11df-8246-59ba6e8696e0
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear CHORNY,
    
This is a computer-generated error report created automatically by
CPANPLUS, version 0.9007. Testers personal comments may appear 
at the end of this report.


Thank you for uploading your work to CPAN.  However, it appears that
there were some problems testing your distribution.

TEST RESULTS:

Below is the error stack from stage 'fetch':

[MSG] [Sat Aug 14 05:22:44 2010] Found locale    C
Use of inherited AUTOLOAD for non-method Module::Install::Msgfmt::install_share() is deprecated at inc/Module/Install/Msgfmt.pm line 21.
Padre requires a perl built using threads

[ERROR] [Sat Aug 14 05:22:44 2010] File '/home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Padre-0.68/Makefile' is not readable or does not exist
[ERROR] [Sat Aug 14 05:22:44 2010] Unable to scan '/home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Padre-0.68/Makefile' for prereqs
[ERROR] [Sat Aug 14 05:22:44 2010] Unable to create a new distribution object for 'Padre::PluginBuilder' -- cannot continue
[ERROR] [Sat Aug 14 05:22:44 2010] Failed to install 'Padre::PluginBuilder' as prerequisite for 'Padre::Plugin::PAR'
[ERROR] [Sat Aug 14 05:22:44 2010] Unable to satisfy 'configure_requires' for 'Padre::Plugin::PAR' -- aborting install


Perl module toolchain versions installed:
	Module Name                        Have
	CPANPLUS                         0.9007
	CPANPLUS::Dist::Build              0.46
	Cwd                                3.31
	ExtUtils::CBuilder               0.2703
	ExtUtils::Command                  1.16
	ExtUtils::Install                  1.55
	ExtUtils::MakeMaker                6.56
	ExtUtils::Manifest                 1.58
	ExtUtils::ParseXS                2.2206
	File::Spec                         3.31
	Module::Build                    0.3607
	Test::Harness                      3.21
	Test::More                         0.94
	version                            0.82

******************************** NOTE ********************************
The comments above are created mechanically, possibly without manual
checking by the sender.  As there are many people performing automatic
tests on each upload to CPAN, it is likely that you will receive 
identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first
one with correction and/or additional informations, and do not take
it personally.  We appreciate your patience. :)
**********************************************************************

Additional comments:
 

This report was machine-generated by CPANPLUS::Dist::YACSmoke 0.58.
Powered by minismokebox version 0.26

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    PATH = /home/cpan/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R7/bin:/usr/X11R6/bin:/usr/pkg/bin:/usr/pkg/sbin:/usr/games:/usr/local/bin:/usr/local/sbin
    PERL5LIB = :/home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Alien-wxWidgets-0.51/blib/lib:/home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Alien-wxWidgets-0.51/blib/arch
    PERL5_CPANPLUS_IS_RUNNING = 29815
    PERL5_CPANPLUS_IS_VERSION = 0.9007
    PERL5_MINISMOKEBOX = 0.26
    PERL5_YACSMOKE_BASE = /home/cpan/pit/64bit/conf/perl-5.12.0
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /usr/pkg/bin/bash
    TERM = screen

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /home/cpan/pit/64bit/perl-5.12.0/bin/perl
    UID:  $<  = 1000
    EUID: $>  = 1000
    GID:  $(  = 100 100
    EGID: $)  = 100 100


-------------------------------


--

Summary of my perl5 (revision 5 version 12 subversion 0) configuration:
   
  Platform:
    osname=netbsd, osvers=5.0.2, archname=i386-netbsd-64int
    uname='netbsd neville.bingosnet.co.uk 5.0.2 netbsd 5.0.2 (generic) #0: sat feb 6 17:53:27 utc 2010 builds@b7.netbsd.org:homebuildsabnetbsd-5-0-2-releasei386201002061851z-objhomebuildsabnetbsd-5-0-2-releasesrcsysarchi386compilegeneric i386 '
    config_args='-des -Dprefix=/home/cpan/pit/64bit/perl-5.12.0 -Dusemallocwrap=y -Dusemymalloc=n -Duse64bitint'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/pkg/include',
    optimize='-O',
    cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/pkg/include'
    ccversion='', gccversion='4.1.3 20080704 prerelease (NetBSD nb2 20081120)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -Wl,-rpath,/usr/pkg/lib -Wl,-rpath,/usr/local/lib -fstack-protector -L/usr/pkg/lib'
    libpth=/usr/pkg/lib /lib /usr/lib
    libs=-lm -lcrypt -lutil -lc -lposix
    perllibs=-lm -lcrypt -lutil -lc -lposix
    libc=/lib/libc.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E '
    cccdlflags='-DPIC -fPIC ', lddlflags='--whole-archive -shared  -L/usr/pkg/lib -fstack-protector'


Characteristics of this binary (from libperl): 
  Compile-time options: PERL_DONT_CREATE_GVSV PERL_MALLOC_WRAP USE_64_BIT_INT
                        USE_LARGE_FILES USE_PERLIO USE_PERL_ATOF
  Built under netbsd
  Compiled at Jul 25 2010 19:35:19
  %ENV:
    PERL5LIB=":/home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Alien-wxWidgets-0.51/blib/lib:/home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Alien-wxWidgets-0.51/blib/arch"
    PERL5_CPANPLUS_IS_RUNNING="29815"
    PERL5_CPANPLUS_IS_VERSION="0.9007"
    PERL5_MINISMOKEBOX="0.26"
    PERL5_YACSMOKE_BASE="/home/cpan/pit/64bit/conf/perl-5.12.0"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Alien-wxWidgets-0.51/blib/lib
    /home/cpan/pit/64bit/conf/perl-5.12.0/.cpanplus/5.12.0/build/Alien-wxWidgets-0.51/blib/arch
    /home/cpan/pit/64bit/perl-5.12.0/lib/site_perl/5.12.0/i386-netbsd-64int
    /home/cpan/pit/64bit/perl-5.12.0/lib/site_perl/5.12.0
    /home/cpan/pit/64bit/perl-5.12.0/lib/5.12.0/i386-netbsd-64int
    /home/cpan/pit/64bit/perl-5.12.0/lib/5.12.0
    .