Win32-Process v0.17 Perl 5 v5.36.0 darwin-thread-multi-ld-2level

Status
Na
From
Dist
Win32-Process v0.17
Platform
Perl 5 v5.36.0 darwin-thread-multi-ld-2level
Date
2023-04-14T19:27:22
ID
612da37c-dafa-11ed-8c32-e4eeca2138b9
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Jan Dubois,

This is a computer-generated report for Win32-Process-0.17
on perl 5.36.0, created by CPAN-Reporter-1.2018.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

none provided

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/opt/perl5/perls/perl-5.36.0/bin/perl5.36.0 Makefile.PL':

OS unsupported

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

    No requirements found

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    CPAN_RUN_SHELL_TEST_WITHOUT_EXPECT = 1
    LANG = en_US.UTF-8
    LC_ADDRESS = en_US.UTF-8
    LC_ALL = en_US.UTF-8
    LC_COLLATE = C
    LC_IDENTIFICATION = en_US.UTF-8
    LC_MEASUREMENT = en_US.UTF-8
    LC_MESSAGES = POSIX
    LC_MONETARY = en_US.UTF-8
    LC_NAME = en_US.UTF-8
    LC_NUMERIC = en_US.UTF-8
    LC_PAPER = en_US.UTF-8
    LC_TELEPHONE = en_US.UTF-8
    LC_TERMINAL = iTerm2
    LC_TERMINAL_VERSION = 3.5.0beta10
    LC_TIME = en_US.UTF-8
    LDFLAGS = -Wl,-syslibroot,/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk -mmacosx-version-min=13 -L/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX13.3.sdk/usr/lib -L/usr/local/lib -L/usr/local/opt/openssl@1.1/lib -L/usr/local/opt/readline/lib -L/usr/local/opt/zlib/lib -L/usr/local/opt/bzip2/lib -L/usr/local/opt/icu4c/lib -L/usr/local/opt/expat/lib -L/usr/local/opt/libxslt/lib -L/usr/local/opt/libxml2/lib -L/usr/local/opt/bison/lib -L/usr/local/opt/berkeley-db/lib -L/usr/local/opt/sqlite/lib -L/usr/local/opt/libarchive/lib
    NONINTERACTIVE_TESTING = 1
    PATH = /Users/b1-bloom/.local/bin:/Users/b1-bloom/.cargo/bin:/usr/local/opt/libtool/libexec/gnubin:/usr/local/opt/gnupg/bin:/Users/b1-bloom/.bin:/opt/perl5/bin:/opt/perl5/perls/perl-5.36.0/bin:/Users/b1-bloom/Library/Python/3.11/bin:/Users/b1-bloom/Library/Python/3.10/bin:/Users/b1-bloom/Library/Python/3.9/bin:/Users/b1-bloom/.pyenv/bin:/Users/b1-bloom/.rbenv/bin:/Users/b1-bloom/.jenv/shims:/Users/b1-bloom/.jenv/bin:/opt/luarocks/bin:/usr/local/opt/luajit-openresty/bin:/Users/b1-bloom/.mint/bin:/Users/b1-bloom/Bloom-Development/Bloom-Project/B1-Local/B1-GOLANG/bin:/usr/local/opt/go/libexec/bin:/Users/b1-bloom/.deno/bin:/usr/local/opt/autoconf/bin:/usr/local/opt/gnu-which/libexec/gnubin:/usr/local/opt/grep/libexec/gnubin:/usr/local/opt/bison/bin:/opt/metasploit-framework/bin:/usr/local/opt/ncurses/bin:/usr/local/opt/awk/bin:/usr/local/opt/berkeley-db/bin:/usr/local/opt/lsof/bin:/usr/local/opt/git/bin:/usr/local/opt/rtmpdump/bin:/usr/local/opt/unzip/bin:/usr/local/opt/bzip2/bin:/usr/local/opt/libarchive/bin:/usr/local/opt/expat/bin:/usr/local/opt/libxslt/bin:/usr/local/opt/libxml2/bin:/usr/local/opt/sqlite/bin:/usr/local/opt/man-db/sbin:/usr/local/opt/man-db/bin:/usr/local/opt/apr-util/bin:/usr/local/opt/apr/bin:/usr/local/opt/icu4c/sbin:/usr/local/opt/icu4c/bin:/Applications/Visual Studio Code - Insiders.app/Contents/Resources/app/bin:/opt/DevTools/DictionaryDevelopmentKit/bin:/Users/b1-bloom/.yarn/bin:/Users/b1-bloom/.osx-sysdir/FinderMD/bin:/usr/local/opt/openssl@1.1/bin:/Users/b1-bloom/.pyenv/plugins/pyenv-virtualenv/shims:/Users/b1-bloom/.pyenv/shims:/Users/b1-bloom/.nvm/versions/node/v19.9.0/bin:/Users/b1-bloom/.rbenv/shims:/usr/local/bin:/usr/local/sbin:/Library/Apple/usr/bin:/usr/bin:/usr/sbin:/bin:/sbin:/System/Cryptexes/App/usr/bin:/usr/local/MacGPG2/bin:/opt/X11/bin:/Applications/Wireshark.app/Contents/MacOS:/var/run/com.apple.security.cryptexd/codex.system/bootstrap/usr/local/bin:/var/run/com.apple.security.cryptexd/codex.system/bootstrap/usr/bin:/var/run/com.apple.security.cryptexd/codex.system/bootstrap/usr/appleinternal/bin:/usr/libexec:/System/Library/CoreServices:/Applications/iTerm.app/Contents/Resources/utilities:/Users/b1-bloom/.composer/vendor/bin:/Users/b1-bloom/.fzf/bin
    PERL = /opt/perl5/perls/perl-5.36.0/bin/perl5.36.0
    PERL5LIB = 
    PERL5OPT = -I/var/folders/jn/jcn2g_t16f9b_gpcjvfgzvs80000gn/T/CPAN-Reporter-lib-CdNr -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 71441
    PERL5_CPAN_IS_EXECUTING = /Users/b1-bloom/.cpan/build/Win32-Process-0.17-0/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 71441
    PERLBREW_CPAN_MIRROR = https://cpan.metacpan.org
    PERLBREW_HOME = /Users/b1-bloom/.perlbrew
    PERLBREW_MANPATH = /opt/perl5/perls/perl-5.36.0/man
    PERLBREW_PATH = /opt/perl5/bin:/opt/perl5/perls/perl-5.36.0/bin
    PERLBREW_PERL = perl-5.36.0
    PERLBREW_ROOT = /opt/perl5
    PERLBREW_SHELLRC_VERSION = 0.96
    PERLBREW_VERSION = 0.96
    PERL_AUTOINSTALL = 1
    PERL_CPANM_OPT = -v --with-recommends --with-suggests --man-pages --auto-cleanup
    PERL_EXTUTILS_AUTOINSTALL = 1
    PERL_MM_USE_DEFAULT = 1
    PERL_USE_UNSAFE_INC = 1
    SHELL = /usr/local/bin/zsh
    TERM = xterm-256color
    TMPDIR = /var/folders/jn/jcn2g_t16f9b_gpcjvfgzvs80000gn/T/

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /opt/perl5/perls/perl-5.36.0/bin/perl5.36.0
    $UID/$EUID = 501 / 501
    $GID = 20 20 12 61 79 80 81 98 399 400 101 705 703 33 100 702 704
    $EGID = 20 20 12 61 79 80 81 98 399 400 101 705 703 33 100 702 704

Perl module toolchain versions installed:

    Module              Have    
    ------------------- --------
    CPAN                2.34    
    CPAN::Meta          2.150010
    Cwd                 3.84    
    ExtUtils::CBuilder  0.280236
    ExtUtils::Command   7.70    
    ExtUtils::Install   2.22    
    ExtUtils::MakeMaker 7.70    
    ExtUtils::Manifest  1.73    
    ExtUtils::ParseXS   3.45    
    File::Spec          3.84    
    JSON                4.10    
    JSON::PP            4.16    
    Module::Build       0.4232  
    Module::Signature   0.88    
    Parse::CPAN::Meta   2.150010
    Test::Harness       3.44    
    Test::More          1.302194
    YAML                1.30    
    YAML::Syck          1.34    
    version             0.9929  


--

Summary of my perl5 (revision 5 version 36 subversion 0) configuration:
   
  Platform:
    osname=darwin
    osvers=22.5.0
    archname=darwin-thread-multi-ld-2level
    uname='darwin ast-03.local 22.5.0 darwin kernel version 22.5.0: fri mar 17 14:37:58 pdt 2023; root:xnu-8796.120.16~15release_x86_64 x86_64 '
    config_args='-de -Dprefix=/opt/perl5/perls/perl-5.36.0 -Duseshrplib -Duselargefiles -Dusethreads -Dusedevel -Dsed=/usr/bin/sed -Doptimize=-O3 -Dusethreads -Duse64bitint -Dcc=clang -Dusemultiplicity -Duselongdouble -Aeval:scriptdir=/opt/perl5/perls/perl-5.36.0/bin'
    hint=recommended
    useposix=true
    d_sigaction=define
    useithreads=define
    usemultiplicity=define
    use64bitint=define
    use64bitall=define
    uselongdouble=define
    usemymalloc=n
    default_inc_excludes_dot=define
  Compiler:
    cc='clang'
    ccflags ='-fno-common -DPERL_DARWIN -no-cpp-precomp -mmacosx-version-min=13.4 -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include -DPERL_USE_SAFE_PUTENV'
    optimize='-O3'
    cppflags='-no-cpp-precomp -fno-common -DPERL_DARWIN -no-cpp-precomp -mmacosx-version-min=13.4 -fno-strict-aliasing -pipe -fstack-protector-strong -I/usr/local/include'
    ccversion=''
    gccversion='Apple LLVM 14.0.3 (clang-1403.0.22.14.1)'
    gccosandvers=''
    intsize=4
    longsize=8
    ptrsize=8
    doublesize=8
    byteorder=12345678
    doublekind=3
    d_longlong=define
    longlongsize=8
    d_longdbl=define
    longdblsize=16
    longdblkind=3
    ivtype='long'
    ivsize=8
    nvtype='long double'
    nvsize=16
    Off_t='off_t'
    lseeksize=8
    alignbytes=16
    prototype=define
  Linker and Libraries:
    ld='clang'
    ldflags =' -mmacosx-version-min=13.4 -fstack-protector-strong -L/usr/local/lib'
    libpth=/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib/clang/14.0.3/lib /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk/usr/lib /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/lib /usr/local/lib /usr/lib
    libs=-lgdbm -ldbm
    perllibs=
    libc=
    so=dylib
    useshrplib=true
    libperl=libperl.dylib
    gnulibc_version=''
  Dynamic Linking:
    dlsrc=dl_dlopen.xs
    dlext=bundle
    d_dlsymun=undef
    ccdlflags=' '
    cccdlflags=' '
    lddlflags=' -mmacosx-version-min=13.4 -bundle -undefined dynamic_lookup -L/usr/local/lib -fstack-protector-strong'


Characteristics of this binary (from libperl): 
  Compile-time options:
    HAS_TIMES
    MULTIPLICITY
    PERLIO_LAYERS
    PERL_COPY_ON_WRITE
    PERL_DONT_CREATE_GVSV
    PERL_MALLOC_WRAP
    PERL_OP_PARENT
    PERL_PRESERVE_IVUV
    PERL_USE_DEVEL
    PERL_USE_SAFE_PUTENV
    USE_64_BIT_ALL
    USE_64_BIT_INT
    USE_ITHREADS
    USE_LARGE_FILES
    USE_LOCALE
    USE_LOCALE_COLLATE
    USE_LOCALE_CTYPE
    USE_LOCALE_NUMERIC
    USE_LOCALE_TIME
    USE_LONG_DOUBLE
    USE_PERLIO
    USE_PERL_ATOF
    USE_REENTRANT_API
    USE_THREAD_SAFE_LOCALE
  Built under darwin
  Compiled at Apr 11 2023 23:49:22
  %ENV:
    PERL="/opt/perl5/perls/perl-5.36.0/bin/perl5.36.0"
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="71441"
    PERL5_CPAN_IS_EXECUTING="/Users/b1-bloom/.cpan/build/Win32-Process-0.17-0/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="71441"
    PERLBREW_CPAN_MIRROR="https://cpan.metacpan.org"
    PERLBREW_HOME="/Users/b1-bloom/.perlbrew"
    PERLBREW_MANPATH="/opt/perl5/perls/perl-5.36.0/man"
    PERLBREW_PATH="/opt/perl5/bin:/opt/perl5/perls/perl-5.36.0/bin"
    PERLBREW_PERL="perl-5.36.0"
    PERLBREW_ROOT="/opt/perl5"
    PERLBREW_SHELLRC_VERSION="0.96"
    PERLBREW_VERSION="0.96"
    PERL_AUTOINSTALL="1"
    PERL_CPANM_OPT="-v --with-recommends --with-suggests --man-pages --auto-cleanup"
    PERL_EXTUTILS_AUTOINSTALL="1"
    PERL_MM_USE_DEFAULT="1"
    PERL_USE_UNSAFE_INC="1"
  @INC:
    /opt/perl5/perls/perl-5.36.0/lib/site_perl/5.36.0/darwin-thread-multi-ld-2level
    /opt/perl5/perls/perl-5.36.0/lib/site_perl/5.36.0
    /opt/perl5/perls/perl-5.36.0/lib/5.36.0/darwin-thread-multi-ld-2level
    /opt/perl5/perls/perl-5.36.0/lib/5.36.0
    .