Padre-Plugin-PAR v0.06 Perl 5 v5.12.1 alpha-linux-thread-multi

Status
Unknown
From
Chris Williams (BINGOS)
Dist
Padre-Plugin-PAR v0.06
Platform
Perl 5 v5.12.1 alpha-linux-thread-multi
Date
2010-08-14T14:36:34
ID
56936e9a-a7b1-11df-8246-59ba6e8696e0
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--

Dear CHORNY,
    
This is a computer-generated error report created automatically by
CPANPLUS, version 0.9007. Testers personal comments may appear 
at the end of this report.


Thank you for uploading your work to CPAN.  However, it appears that
there were some problems testing your distribution.

TEST RESULTS:

Below is the error stack from stage 'fetch':

[ERROR] [Sat Aug 14 15:36:33 2010] MAKE failed:
Building Alien-wxWidgets
configure: error: cannot run /bin/sh ../config.sub
system: echo exit | sh ../configure --prefix=/home/cpan/pit/rel/perl-5.12.1/lib/site_perl/5.12.1/alpha-linux-thread-multi/Alien/wxWidgets/gtk_2_8_10_uni --with-gtk --disable-compat24 --enable-unicode --disable-debug --disable-monolithic --disable-universal_binary : 256 at /home/cpan/pit/rel/conf/perl-5.12.1/.cpanplus/5.12.1/build/Alien-wxWidgets-0.51/Build line 59
BEGIN failed--compilation aborted at /home/cpan/pit/rel/perl-5.12.1/bin/cpanp-run-perl line 8.

[MSG] [Sat Aug 14 15:36:34 2010] Sending test report for 'Alien-wxWidgets-0.51'
[MSG] [Sat Aug 14 15:36:34 2010] Ok, not sending test report
[ERROR] [Sat Aug 14 15:36:34 2010] Unable to create a new distribution object for 'Alien::wxWidgets' -- cannot continue
[ERROR] [Sat Aug 14 15:36:34 2010] Failed to install 'Alien::wxWidgets' as prerequisite for 'Padre::PluginBuilder'
[ERROR] [Sat Aug 14 15:36:34 2010] Unable to satisfy 'configure_requires' for 'Padre::PluginBuilder' -- aborting install
[ERROR] [Sat Aug 14 15:36:34 2010] Unable to create a new distribution object for 'Padre::PluginBuilder' -- cannot continue
[ERROR] [Sat Aug 14 15:36:34 2010] Failed to install 'Padre::PluginBuilder' as prerequisite for 'Padre::Plugin::PAR'
[ERROR] [Sat Aug 14 15:36:34 2010] Unable to satisfy 'configure_requires' for 'Padre::Plugin::PAR' -- aborting install


Perl module toolchain versions installed:
	Module Name                        Have
	CPANPLUS                         0.9007
	CPANPLUS::Dist::Build              0.46
	Cwd                                3.31
	ExtUtils::CBuilder               0.2703
	ExtUtils::Command                  1.16
	ExtUtils::Install                  1.55
	ExtUtils::MakeMaker                6.56
	ExtUtils::Manifest                 1.58
	ExtUtils::ParseXS                2.2206
	File::Spec                         3.31
	Module::Build                    0.3607
	Test::Harness                      3.21
	Test::More                         0.94
	version                            0.82

******************************** NOTE ********************************
The comments above are created mechanically, possibly without manual
checking by the sender.  As there are many people performing automatic
tests on each upload to CPAN, it is likely that you will receive 
identical messages about the same problem.

If you believe that the message is mistaken, please reply to the first
one with correction and/or additional informations, and do not take
it personally.  We appreciate your patience. :)
**********************************************************************

Additional comments:
 

This report was machine-generated by CPANPLUS::Dist::YACSmoke 0.58.
Powered by minismokebox version 0.26

------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_GB.UTF-8
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/games
    PERL5_CPANPLUS_IS_RUNNING = 5399
    PERL5_CPANPLUS_IS_VERSION = 0.9007
    PERL5_MINISMOKEBOX = 0.26
    PERL5_YACSMOKE_BASE = /home/cpan/pit/rel/conf/perl-5.12.1
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = screen.linux

Perl special variables (and OS-specific diagnostics, for MSWin32):

    Perl: $^X = /home/cpan/pit/rel/perl-5.12.1/bin/perl
    UID:  $<  = 1001
    EUID: $>  = 1001
    GID:  $(  = 1001 1001
    EGID: $)  = 1001 1001


-------------------------------


--

Summary of my perl5 (revision 5 version 12 subversion 1) configuration:
   
  Platform:
    osname=linux, osvers=2.6.26-2-alpha-generic, archname=alpha-linux-thread-multi
    uname='linux debauch 2.6.26-2-alpha-generic #1 tue mar 9 22:27:23 utc 2010 alpha gnulinux '
    config_args='-des -Dprefix=/home/cpan/pit/rel/perl-5.12.1 -Dusethreads'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='4.2.4 (Debian 4.2.4-6)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.7'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_PERL_ATOF USE_REENTRANT_API
  Built under linux
  Compiled at May 18 2010 13:19:41
  %ENV:
    PERL5_CPANPLUS_IS_RUNNING="5399"
    PERL5_CPANPLUS_IS_VERSION="0.9007"
    PERL5_MINISMOKEBOX="0.26"
    PERL5_YACSMOKE_BASE="/home/cpan/pit/rel/conf/perl-5.12.1"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/cpan/pit/rel/perl-5.12.1/lib/site_perl/5.12.1/alpha-linux-thread-multi
    /home/cpan/pit/rel/perl-5.12.1/lib/site_perl/5.12.1
    /home/cpan/pit/rel/perl-5.12.1/lib/5.12.1/alpha-linux-thread-multi
    /home/cpan/pit/rel/perl-5.12.1/lib/5.12.1
    .