Padre-Plugin-Perl6 v0.71 Perl 5 v5.8.9 i686-linux

Status
Na
From
Serguei Trouchelle (STRO)
Dist
Padre-Plugin-Perl6 v0.71
Platform
Perl 5 v5.8.9 i686-linux
Date
2010-12-16T06:09:16
ID
032eb5b2-08db-11e0-a235-dd237fc525be
This distribution has been tested as part of the CPAN Testers
project, supporting the Perl programming language.  See
http://wiki.cpantesters.org/ for more information or email
questions to cpan-testers-discuss@perl.org


--
Dear Ahmad M. Zawawi,

This is a computer-generated report for Padre-Plugin-Perl6-0.71
on perl 5.8.9, created by CPAN-Reporter-1.1803.

Thank you for uploading your work to CPAN.  While attempting to build or test
this distribution, the distribution signaled that support is not available
either for this operating system or this version of Perl.  Nevertheless, any
diagnostic output produced is provided below for reference.  If this is not
what you expect, you may wish to consult the CPAN Testers Wiki:

http://wiki.cpantesters.org/wiki/CPANAuthorNotes

Sections of this report:

    * Tester comments
    * Program output
    * Prerequisites
    * Environment and other context

------------------------------
TESTER COMMENTS
------------------------------

Additional comments from tester:

this report is from an automated smoke testing program
and was not reviewed by a human for accuracy

------------------------------
PROGRAM OUTPUT
------------------------------

Output from '/home/stro/perl/perl589m/bin/perl Makefile.PL':

Perl v5.10.0 required--this is only v5.8.9, stopped at Makefile.PL line 5.
BEGIN failed--compilation aborted at Makefile.PL line 5.

------------------------------
PREREQUISITES
------------------------------

Prerequisite modules loaded:

configure_requires:

    Module                  Need Have
    ----------------------- ---- ----
    ExtUtils::MakeMaker     6.31 6.56
    File::ShareDir::Install 0.03 0.03


------------------------------
ENVIRONMENT AND OTHER CONTEXT
------------------------------

Environment variables:

    AUTOMATED_TESTING = 1
    LANG = en_US.UTF-8
    PATH = /usr/local/bin:/usr/bin:/bin:/usr/games
    PERL5LIB = 
    PERL5OPT = -I/tmp/CPAN-Reporter-lib-JbJn -MDevel::Autoflush
    PERL5_CPANPLUS_IS_RUNNING = 30895
    PERL5_CPAN_IS_EXECUTING = /home/stro/cpan/build/5.8.9-m/Padre-Plugin-Perl6-0.71-vJaVqC/Makefile.PL
    PERL5_CPAN_IS_RUNNING = 30895
    PERL5_CPAN_IS_RUNNING_IN_RECURSION = 29749,30895
    PERL_CR_SMOKER_CURRENT = Padre-Plugin-Perl6-0.71
    PERL_EXTUTILS_AUTOINSTALL = --defaultdeps
    PERL_MM_USE_DEFAULT = 1
    SHELL = /bin/bash
    TERM = xterm

Perl special variables (and OS-specific diagnostics, for MSWin32):

    $^X = /home/stro/perl/perl589m/bin/perl
    $UID/$EUID = 1000 / 1000
    $GID = 1000 20 24 25 29 44 46 1000
    $EGID = 1000 20 24 25 29 44 46 1000

Perl module toolchain versions installed:

    Module              Have  
    ------------------- ------
    CPAN                1.9402
    Cwd                 3.33  
    ExtUtils::CBuilder  0.2801
    ExtUtils::Command   1.16  
    ExtUtils::Install   1.52  
    ExtUtils::MakeMaker 6.56  
    ExtUtils::Manifest  1.56  
    ExtUtils::ParseXS   2.2206
    File::Spec          3.33  
    Module::Build       0.3607
    Module::Signature   0.66  
    Test::Harness       3.22  
    Test::More          0.96  
    YAML                0.71  
    YAML::Syck          1.17  
    version             0.85  


--

Summary of my perl5 (revision 5 version 8 subversion 9) configuration:
  Platform:
    osname=linux, osvers=2.6.26-2-686, archname=i686-linux-multi
    uname='linux debian5 2.6.26-2-686 #1 smp wed may 12 21:56:10 utc 2010 i686 gnulinux '
    config_args=''
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=define
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fno-strict-aliasing -pipe -I/usr/local/include'
    ccversion='', gccversion='4.3.2', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.7.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.7'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib'


Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP
                        USE_FAST_STDIO USE_LARGE_FILES USE_PERLIO
  Built under linux
  Compiled at Jun 16 2010 17:14:57
  %ENV:
    PERL5LIB=""
    PERL5OPT=""
    PERL5_CPANPLUS_IS_RUNNING="30895"
    PERL5_CPAN_IS_EXECUTING="/home/stro/cpan/build/5.8.9-m/Padre-Plugin-Perl6-0.71-vJaVqC/Makefile.PL"
    PERL5_CPAN_IS_RUNNING="30895"
    PERL5_CPAN_IS_RUNNING_IN_RECURSION="29749,30895"
    PERL_CR_SMOKER_CURRENT="Padre-Plugin-Perl6-0.71"
    PERL_EXTUTILS_AUTOINSTALL="--defaultdeps"
    PERL_MM_USE_DEFAULT="1"
  @INC:
    /home/stro/perl/perl589m/lib/5.8.9/i686-linux-multi
    /home/stro/perl/perl589m/lib/5.8.9
    /home/stro/perl/perl589m/lib/site_perl/5.8.9/i686-linux-multi
    /home/stro/perl/perl589m/lib/site_perl/5.8.9
    .